Videoconference setup


#1

Goodmorning everyone. I’m setting up a video conference on a FreePBX 12.0.76.6 switchboard.

The current situation is this:
Now the conference works as audio. It works very well, they connect to the conference both via external and internal calls with the Zoiper softphone application. There is the administrator who has an input pin and the users a different one who accesses them with the microphone off. The management of the microphones and the connected ones is done with Fop2.
At the moment they asked me the same thing only by videoconference. I read that it can also be done with version 12.
I did some tests and got to this point: Using the linphone application on Android devices everyone connects well to the conference with their own pin and the microphone is ok. However, the video stream does not come out, each device sees what its video camera transmits, but not what is transmitted by the others.

What could be a reason for this malfunction?

Thanks in advance for all the tips and guides you can give me


#2

I do not know about FreePBX 12, as it has been some time since I have used it. I know that with the current version of FreePBX, video conference settings are not available in the GUI and you have to set them using the custom conf files.

Depending on what you want to accomplish, you may be better off using a hosted service for video conferencing. With Asterisk and standard SIP clients like Zoiper, you cannot show multiple video streams at once on the screen (“MCU”). The best you will get is “follow-talker” which will switch the video stream each time someone talks.


#3

is the “follow-talker” more than fine, is it to be activated somewhere or is it already included when activating “enable video” on the “chan sip” settings?


#4

Here is the asterisk wiki for reference: https://wiki.asterisk.org/wiki/display/AST/ConfBridge+Configuration

On my system, I edited the file /etc/asterisk/confbridge_custom.conf to modify the default bridge profile:

[default_bridge](+)
video_mode=follow_talker

(Dave Burgess) #5

A quick suggestion - could you submit that as a Feature Request. Since it’s the only “video mode” that works, it would seem like a good idea to have that added to the confbridge.conf file as a default…


#6

Feature requested in February 2019: https://issues.freepbx.org/browse/FREEPBX-19546