Video not available (but previously was)

Hi to all, first time requesting help here but I don’t know where to bang my head anymore.

I recently installed a Fanvil i62 Doorphone. Configured, it worked fine instantly with video too.
Now after a few days, without ANY update, without ANY change in the configuration at all (both on the PBX and the device) video isn’t working anymore. I tried updating the firmware of the device to the latest version with no luck.

The error that comes up is this:

res_srtp.c: SRTP unprotect failed on SSRC 1572037322 because of authentication failure 10
res_srtp.c: SRTCP unprotect failed on SSRC 1142971535 because of authentication failure
res_srtp.c: SRTP unprotect failed on SSRC 1572037322 because of authentication failure 160
(keeps repeating)

Audio works fine, only the video isn’t available anymore. I tested the video between two softphones (Linphone) and it works fine.
The extension has TLS and SRTP enabled but even disabling them seems to not change anything (even that log above keeps popping up strangely). Rebooting or creating a new extension didn’t help.

I would have tried to update libsrtp to the much newer 2.5.0 but it isn’t available through standard updates (maybe by building it from source but will it work?)

Some information about my system:
Asterisk v.16.30.0
FreePBX v. w/ CentOS 7
libsrtp v.1.6.0

Little correction: the error does not popup with UDP only, no message at all. Could someone point me in the right direction to debug this strange problem?
I think I read somewhere that it could also be the stream itself to be malformed, maybe?

I also tried with another fanvil i61 that I had laying around on another network but the same exact problem.

I was thinking of analyzing the traffic with Wireshark (and temporarily set the extension to UDP for simplicity). Is there something specific to look for?

I didn’t have the time to look at the packets yet, but I found some interesting messages inside the log of the device:

E/mscore | Camera is proposing a size bigger than encoder's suggested size (1280x720 > 1024x768) Using the camera size as fallback because cropping or resizing is not implemented for this device.
E/mscore | no such method on filter FHVideoCapture, fid=16387 method index=13

Maybe it is a problem on the device itself? I will keep you informed.

EDIT: By setting video resolution to CIF the first error disappear, but still no video.

By looking at the RTP debug nothing is wrong, I got a lot or RTP packets with payload 99 correctly forwarded to the correct IP.

core show channel channel-name

shows instead a strange thing: the stream for video coming from the doorbell that should be set to sendonly is instead set to recvonly! Can’t understand why, in the fanvil I correctly set the parameter to sendonly. I will have a look at this with high hopes :crossed_fingers:

EDIT: nope still not working. I will post on the asterisk forum maybe they know better!

After many debugging and research I found the problem was the router on the doorphone side. I did change it but I didn’t remember so the problems all started there…

The router is a Tenda 4G03 (a 4G router). I tried disabling the firewall and everything but nothing helped. The cause I think it is the slow speed achieved by this device or some strange firmware firewall that blocks some types of connections. Switching back to the trusted YPLink Archer MR200 fixes everything (I changed it because it had some other problems).

Long story short: at least for me, do not use a Tenda 4g router with FreePBX/asterisk!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.