Very Minor Things

Have done two installs and got a few very minor things on both. Otherwise the distro is fantastic, I have tried them all at one time or another and this is by far the easiest and most hassle free to deal with, great work to those who built it.

I found that after the install under System Admin - Networking the gateway address I entered during the install did not show up and nether did the Interface Mac address.

Under Time Zone the Time Zone I entered (St. Kitts) did not show up, it showed Anguilla - most likely that is the first one in the list for the Americas but is the same Time Zone as me so had not adverse effects.

When loading the Dahdi module from the extended repository I got a simlink error. Cured by renaming the .conf file and reloading.

Loaded fop2 and it hangs when called from the freepbx button but runs OK when called direct to the url from the browser.

I like to have phpMyadmin and Webmin available on my boxes. Webmin was simple yum install Webmin and it was done. I found phpMyAdmin had in fact been installed but did not work. It was pretty simple to sort out and get running, if anyone is interested will be happy to share my notes.

I have added a couple of links to the Freepbx/Schmooze starter screen for phpMyAdmin and Webmin and a bit of code to display IP address and hostname on that screeen to identify the system when you have several different systems running.

Am now pushing on with testing all functionality, so far so good, everything working as it should. Again congratulations on an excellent job!


In the phpMyAdmin setup step 6 the authtype should be http not html. Sorry for the slip of the pen!


Sorry to have led you up the garden path on that one, should I just manually enter the gateway and Mac? Although it most likely doesn’t matter.

If you want to take a look at my box on the other issue I have set up VPN access for you, just let me know.

The url ip_address/admin/panel.php from the fpbx button gives the extension/password drop down, after providing these things go no further and can’t connect to server.

The url ip_address/fop2 gives the extension/password drop down, after providing these get registration details drop down, exit this and connects to server and panel comes up.

Ok well that is weird because neither I nor the FOP2 dev can recreate this. Hmmm can someone get us access to a box that is doing this so we can figure out what the issue is.

Sys Admin shows the word gateway in the Gateway box and the words mac address in the MAC Address box.

Routes command gives:

Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 eth0 * U 0 0 0 eth0
default UG 0 0 0 eth0

On the Time Zone I set it on the Anaconda install screen.


Let me sort something out so you can get into my box, it will be by VPN. Can you PM me your email address and I will send you the details.


Way I thought you said earlier we were displaying the wrong gateway address??? Now you are saying it shows blank. That is what it should be doing if you do not have a gateway defined.

Sorry for the confusion, what I did is setup the static IP address and its associated gateway address during the install and was thinking the gateway (and MAC addresses of the interface) should show up in Sys Admin. So you are saying that I am seeing the right thing?

Yes because Linux is not reporting a gateway in the config file for the network which means we wont report showing it. Same with the MAC. Centos does not define the MAC in the network config files by default if there is only one Nic at the time of install.

Ok so what gateway does sysadmin show you are using and what does the route command show you have setup.

We might have a bug in our logic when no gateway is defined in the ifcfg interface.

Also on the time zone thing. Did you manually change the timezone from the command like or did you set the time zone on the initial install screen of anaconda.

On the FOP2 issue what is the URL you are using that works and what URL does not work. Also have you tried clearing your browser cache?

It seems that the Gateway does not appear in that file:

Broadcom Corporation NetXtreme BCM5701 Gigabit Ethernet


ifconfig reports mac address, ip address and net mask as expected - does not report gateway - routes -n does report the expected gateway.

During the install I set the Time Zone to Americas St. Kitts which is on Atlantic Time. When finished and I looked in the System Admin Module it showed the Time Zone as Anguilla. A cat /etc/sysconfig/clock showed Time Zone as Americas/St. Kitts. It appears the sys admin module had not picked up the Time Zone I had set.

Here are the notes I made to get phpMyAdmin running:

  1. Open phpmyadmin.conf

Nano /etc/httpd/conf.d/phpmyadmin.conf and comment out following lines with a leading #:

#Order Deny,Allow
#Deny from all

Control X and save

  1. Restart Apache:

Service httpd restart

  1. Change user permissions on

chown asterisk /usr/share/phpmyadmin/

  1. Find mysql user and password:

nano /etc/amportal.conf and find lines close to the end of the file:

AMPDBPASS=password (where password is the random value provided during installation)

  1. Make a note of these values

  2. Edit

nano /usr/share/phpmyadmin/

change line
$cfg[‘Servers’][$i][‘auth_type’] = ‘cookie’;


$cfg[‘Servers’][$i][‘auth_type’] = ‘html’;

Control X and save

  1. Load mbstring package:

yum install php-mbstring

  1. Run phpMyAdmin in browser http://PBX_IP_Address/phpmyadmin, log on with username and password noted in step 5.

Ok I will look into the timezone issue.

On the network side we look into /etc/sysconfig/network-scripts/ifcfg-eth0 for the gateway setting since setting a route does not belong to a specific interface. What gateway shows in that file.

In sysadmin it reads the gateway address from the ifconfig-ethx interface so whatever centos is reporting there is what we display. What does the interface in centos show as the gateway.

The timezone thing I am confused on. Does the linux CLI show a different time zone than what the timezone GUI in sysadmin show or are they the same.

The issue with DAHDI is a problem with that module and why it is not included by default. This is a module that has lots of issues with it but it is not built or support by the FreePBX team for this reason.

Yes we have webmin in the yum but not installed by default as most people look at webmin as a major security issue and allows users who do know know what they are doing way to much control of things to break things.

What did you change to get phpMyadmin working as I will add those changes into toe distro this week.

I am seeing the same error in regards to Gateway, I setup the system at my office an used DHCP on install, now that I have taken the server to customer site I need to change to a static address, I see in system admin I can set IP address, Subnet mask and DNS, but if you only read gateway settings and can not change it here were is this done. I tried netconfig which is what i used on other distro’s but it doesn’t work, my /etc/sysconfig/network-scripts/ifcfg-eth0 shows no Gateway, can I add simply add GATEWAY=xxxxxxx here. What is the proper procedure.


In sysadmin we display whatever you have setup in your ifcfg files. If you have no gateway we do not display one. You can always set your gateway in the sysadmin module under the network section.

My latest install of the Distro is missing Australia from the timezones completely… is there a message here??/