Version Problem with upgrade module

I want to upgrade to 2.6 from my current 2.5 version on a fresh Trixbox

Following these instructions:

The Upgrade Tool link links to but I get this when I try and install the module:

“A FreePBX version below 2.5.0alpha1 is required, you have 2.5.2”

Followed by ‘Cancel’

I tried to SSH to the module folder and edit the version in the XML file - which allowed it to install - but it didn’t upgrade the FreePBX and then it deleted itself!

Suggestions please? Clean install from the tarball?


Try this link:

Thanks Mikael - that worked a treat but I think I may need to do some editing somewhere.

Getting this when I try and update:

Warning: Cannot connect to online repository ( Online modules are not available.

Where can I change the link?

Appreciate your help.


Please read this thread:

Thanks - followed that through and everything went as planned until I got to the ‘Update Modules’ bit and then got this again:

Warning: Cannot connect to online repository ( Online modules are not available.

It is obviously just going to the wrong repo URL to update - where do I change this? Is it in a file or in the database?

There is nothing wrong with my internet connection - I can yum and I downloaded the FPBX tarball no problem.


Check the file page.modules.php in /var/www/html/admin, that file was probably not replaced.

It should have been updated when framework was updated. Download 2.6 framework and compare the files in that file against yours.

Found my own solution …

I edited /var/www/html/admin/ and changed to and all seems to be working fine.

Thanks for all your help.

It is sad I had to jump through these hoops to get what I wanted. It is the fault of the trixbox fork of course…

But thanks colinjack mickecarlsson and everyone for the info. Here is what I did…

New trixbox iso clean install
updated all pbxconfig modules (maybe I shouldn’t have, and I wouldn’t recommend it if you want the real freepbx anyway.

edited /var/www/html/admin/ and changed to 2 times in this file

Then module update reported and allowed me to download the 2.6 Upgrade Tool, but it gave an error during install…
“A FreePBX version below 2.5.0alpha1 is required, you have 2.5.2”

mysql -uasteriskuser -pamp109
use asterisk;
update modules set version = ‘2.5.0’ where modulename = ‘core’;
vi /var/www/html/admin/modules/versionupgrade/module.xml

in there I changed the version from 2.5.0alpha1 to 2.5.3 (because 2.5.3 is larger than the 2.5.2 that it was reporting that I had)

went back to web interface and the 2.6 upgrade tool worked, and then the 2.6 framework upgrade worked, then upgraded all other modules, then 2.7 upgrade tool, then 2.7 framework, then 2.7 all others.
the nasty 5.5 version was still reported for core and ari, but in 2.7 there seems to be a new option to force a downgrade from 5.5 to 2.7 which worked beautifully for me. Then orange button.

Thanks again everyone, I’ve wearing a big smile right now!!! :slight_smile: