Vega FXO gateway - calls won't connect

My Vega gateway will receive calls and make local calls from FreePBX. However, when I dial a long distance call, the call will not complete, and I get a recorded message from the telco that the call could not complete as dialed.

I am in the USA. In the logs, the call disconnects “call cause 16”. Any ideas on how to get this working?


Not sure, since a SIP failure would have a SIP failure code like 416. Cause 16, from the quick perusal I did, appears to be an improperly formatted outbound phone number. Are you add a ‘1’ that shouldn’t be there, or missing a ‘1’ that should be?

Thanks for the reply, Dave. According to my event log, the correct number is being sent out. I did a factory reset on the Vega, and did a Quick Config to verify that I did not goof anything up. I still get the same response. Incoming works great. Ougoing local calls work great. Long distance will not go.

What number is the Vega dialing? Use 'x for most digits.

I have a resolution to this. Sangoma engineering had me enter these two commands at the Vega command line:


This solved my problem. I hope this helps someone else.