FreePBX | Register | Issues | Wiki | Portal | Support

Vega 60 - Specific Ports for Outbound Routes?


#1

Hey all -

I cannot seem to figure out how to use specific ports for outbound dialing on my Vega 60.

For example, if I dial 7 and then the number, it would go out one port, but if I dialed 8 and then the number, it would go out a different port.

I assume that can be done, but my Googling has turned up nothing.

Any pointers in the right direction would be greatly appreciated.

Thanks!
Jay


#2

Do I perhaps need multiple lines plugged into my Vega for this to work? Right now I’m only testing with a single line.

It’s working, but I really need to be able to choose the outbound connection based on the dialplan.


#3

I’m sure there must be a way of setting the fxo ports individually. It depends on each gateway model. Some require that you create a separate trunk for each fxo port, using a specific udp port for the trunk, others let you use a prepended number that the gateway uses to choose the fxo port and so on. You should check your gateway’s manual to see if your gateway allows this and how to configure if it is allowed.
For the grandstream gateway that I use, the way to do it is with separate trunks for each fxo, where each trunk points to a different udp port.


#4

So it seems I might be able to do this with some fancy dial plan shenanigans, but it’s not working properly and I can’t imagine this is the intended way to do this.

I have an outbound route that uses my Vega 60 as the trunk

image

Under the dial patterns, I have some basic (for now) patterns:

image

I have both a prefix (for dialing from the phone) and a prepend (for triggering my Vega 60):

Since I have phone lines plugged into ports 1, 2 and 7, I set up presentation groups as such:

However, when I call (with 7 to use FXO7):

admin  >
LOG: 01/10/2019 21:11:22.475 ROUTER   (I)R0bC00 FINDROUTE profile:23(To_FXO) plan:8
   call ref=[01da001f]                            <-- SIP     [2,1] dest=NAME:7XXXXXXX,TEL:7XXXXXXX
                                                  --> POTS    [8,1] dest=TEL:7XXXXXXX
LOG: 01/10/2019 21:11:22.475 ROUTER   (I)R0bC00 call proceeding
   call ref=[01da001f]
LOG: 01/10/2019 21:11:22.475 POTS     (I)R1eC00 FXO port 8 line voltage too low
   call ref=[00000000]
LOG: 01/10/2019 21:11:22.475 POTS     (I)R05C1f disconnect call cause 27
   call ref=[01da001f]
LOG: 01/10/2019 21:11:22.475 ROUTER   (I)R0bC00 FINDROUTE profile:23(To_FXO) plan:7
   call ref=[01da001f]                            <-- SIP     [2,1] dest=NAME:7XXXXXXX,TEL:7XXXXXXX
                                                  --> POTS    [7,1] dest=TEL:7XXXXXXX
LOG: 01/10/2019 21:11:25.705 POTS     (I)R03C1f connect call
   call ref=[01da001f]
LOG: 01/10/2019 21:11:25.760 SIP      (I)R03C3b connect g711Ulaw64k (Profile 1 - Voice)
   call ref=[00000000]
LOG: 01/10/2019 21:11:31.175 SIP      (I)R04C3b disconnect(disc ind) 16
   call ref=[01da001f]
LOG: 01/10/2019 21:11:31.175 POTS     (I)R05C1f disconnect call cause 16
   call ref=[01da001f]

It still tries FXO 8 before failing over to 7. I would have expected it to try 7 and only 7.

I see similar logs when I dial with an 8 or 9 (the other two dial plans I have).

I’m at a loss as to why it’s trying 8 and ultimately failing on 7.

Any thoughts?


#5

I was able to make this work, but it included manually changing some of the settings on my Vega 60.

As a recap, I was looking to be able to dial out specific FXO ports based on the dial plan (e.g. - dialing 7 + the number would go out FXO1; dialing 8 + the number would go out FXO2, and so forth).

First I had to set up specific dial plans on my outbound routes:

I set up both a prefix and a prepend. The prefix for the dial plan on the phone and the prepend for selecting the correct FXO port (see below).

Next, I set up some call presentation groups.

It probably wasn’t necessary to set up the second group (for POTS7) as it only has one destination, but I wanted to set up call hunting for my first few FXO ports so it would choose an available port.

Finally, I manually edited the TO_FXO profile to look for the prepend number (from above) and choose the correct FXO port (or call group in this case):

It took a bunch of trial and error, but it seems to be working fine through all my testing.

I am, worried, however, that using the Vega gateway management feature in FreePBX will overwrite my custom config in my Vega 60 if and when I make changes to it via FreePBX. Hopefully that will not be necessary.