Vbuzzer inbound settings

i have Free pbx 2.9.0.12 and have a paid vbuzzer account. outgoing works but i am unable to get incoming to work. it does work on their soft phone and also works on a switchvox. Do not like the lack of control and also not able to setup skype on the switchvox. pretty well have tried what i could find on the net, but to no avail. is there any updated settings or does it not work with freepbx?

From past experience on this forum, people like details. Saying “I am unable to get incoming working” will get you hardly any replies.

You need to elaborate more on why it is not working, what happens when you call the did? what message if any do you get? also people like to see cli log files of inbound calls, to see what is going on.

The more information you give, the more likely you will get a reply to your problem.

I am not trying to sound like an ass, just trying to help you get the needed information that you require.

You may want to look here… http://forum.vbuzzer.com/viewtopic.php?p=9458

Possible reason yours is not working.

Here is something else I found around....

<code>My setup is based on reported settings from different users reported in forums like Vbuzzer's and voip-info.org. The registration string is the only thing with which I must periodically play. Well, here's what my systems basically look like:

[vbuzzer-out]
allow=ulaw,g729,g726
auth=md5
authname=VBusername
canreinvite=no
context=vbuzzer-in
disallow=all
dtmfmode=RFC2833
fromdomain=vbuzzer.com
fromuser=VBusername
host=vbuzzer.com
insecure=very
nat=yes
port=80
qualify=3000
secret=VBpassword
type=peer
user=VBusername
useragent=Vbuzzer/1.1.1.2
username=VBusername

For any given period, one of the following works. Vbuzzer is apparently mucking about with their requirements and it seems to flip-flop between the two formats periodically. If one doesn’t work, change to the other and it will work again!

registration string:

VBusername:VBpassword:[email protected]:80/VBusername

OR !!

VBusername:VBpassword:[email protected]:80/1VBphonenumber

For the inbound context, note that both cases of Vbuzzer expectations are provided so one or the other automatically works;-) I use a ‘9’ prefix for outbound Vbuzzer and the end of each of the sequence one lines below should have a “less than” symbol immediately before the 9${CALLERIDNUM} but I couldn’t figure out how to get it to show and not be interpreted as one of the html tags. For some reason, it would not show here.

[vbuzzer-in]
exten => _1VBphonenumber,1,SetCallerID(“VB:${CALLERIDNAME:1}” <9${CALLERIDNUM}>)
exten => _1VBphonenumber,n,NoOp(Incoming call on Vbuzzer 1VBphonenumber)
exten => _1VBphonenumber,n,Dial(local/[email protected]&sip/cell [email protected],60,m)
exten => _1VBphonenumber,n,Hangup
exten => _1VBphonenumber,n,Voicemail([email protected])

exten => _VBusername,1,SetCallerID(“VB:${CALLERIDNAME:1}” <9${CALLERIDNUM}>)
exten => _VBusername,n,NoOp(Incoming call on Vbuzzer 1VBphonenumber)
exten => _VBusername,n,Dial(local/[email protected]&sip/cell [email protected],60,m)
exten => _VBusername,n,Voicemail([email protected])
exten => _VBusername,n,Hangup
</code>

 

One day, I will figure out how to edit on this forum, and or delete something…

Let me try that one again.

My setup is based on reported settings from different users reported in forums like Vbuzzer’s and voip-info.org. The registration string is the only thing with which I must periodically play. Well, here’s what my systems basically look like:

[vbuzzer-out]
allow=ulaw,g729,g726
auth=md5
authname=VBusername
canreinvite=no
context=vbuzzer-in
disallow=all
dtmfmode=RFC2833
fromdomain=vbuzzer.com
fromuser=VBusername
host=vbuzzer.com
insecure=very
nat=yes
port=80
qualify=3000
secret=VBpassword
type=peer
user=VBusername
useragent=Vbuzzer/1.1.1.2
username=VBusername

For any given period, one of the following works. Vbuzzer is apparently mucking about with their requirements and it seems to flip-flop between the two formats periodically. If one doesn’t work, change to the other and it will work again!

registration string:

VBusername:VBpassword:[email protected]:80/VBusername

OR !!

VBusername:VBpassword:[email protected]:80/1VBphonenumber

For the inbound context, note that both cases of Vbuzzer expectations are provided so one or the other automatically works;-) I use a ‘9’ prefix for outbound Vbuzzer and the end of each of the sequence one lines below should have a “less than” symbol immediately before the 9${CALLERIDNUM} but I couldn’t figure out how to get it to show and not be interpreted as one of the html tags. For some reason, it would not show here.

[vbuzzer-in]
exten => _1VBphonenumber,1,SetCallerID(“VB:${CALLERIDNAME:1}” <9${CALLERIDNUM}>)
exten => _1VBphonenumber,n,NoOp(Incoming call on Vbuzzer 1VBphonenumber)
exten => _1VBphonenumber,n,Dial(local/[email protected]&sip/cell [email protected],60,m)
exten => _1VBphonenumber,n,Hangup
exten => _1VBphonenumber,n,Voicemail([email protected])

exten => _VBusername,1,SetCallerID(“VB:${CALLERIDNAME:1}” <9${CALLERIDNUM}>)
exten => _VBusername,n,NoOp(Incoming call on Vbuzzer 1VBphonenumber)
exten => _VBusername,n,Dial(local/[email protected]&sip/cell [email protected],60,m)
exten => _VBusername,n,Voicemail([email protected])
exten => _VBusername,n,Hangup

well thanks for the input everyone. as far as not supplying incoming log, I had none as the incoming calls were not making past vbuzzer.com. so it seems the incoming was not being registered with vbuzzer. so I changed the registration string as suggested by deanot26508.

VBusername:VBpassword:[email protected]:80/VBusername

So after my excitement of getting it working I turned off

Allow Anonymous Inbound SIP Calls?

So changed my incoming settings on trunk to:

dtmfmode=rfc2833
port=80
canreinvite=no
disallow=all
allow=ulaw&alaw
insecure=port,invite
nat=yes
type=friend
host=vbuzzer.com

not sure if i need all of it but the two most important seem to be host= and
insecure=
the user info was put into th peer section and the user context was set to from-trunk.
be nice i am fairly new to this plus i do not post hardley at all