Valcom VIP-201A Configuration

I am trying to configure a Valcom VIP-201A SIP Paging Server for our FreePBX Distro system. I am having trouble getting the configuration correct so that the VIP-201A is registered to the PBX and is “Reachable”. Here is where I am:

  • Valcom VIP-201A does not like long SIP passwords. I have used a shorter password and now I can get it to register.
  • When I issue a “sip show peers” at the asterisk command line, the device always says “UNREACHABLE”.
  • After some period of time, the device no longer receives incoming calls and therefore, no paging through the Valcom device is available.

I have tried to use both chan_sip and chan_pjsip, with the same basic results. I just can’t seem to find a configuration that works. In the Valcom VIP-102B IP Solutions Setup Tool, I have the SIP configuration set this way:

  • SIP Mode: Station
  • Phone Number: 1234 (The extension number)
  • Description: blank
  • Authentication Name: 1234 (The extension number)
  • Secret: abcd1234ab12 (alpha-numeric password, no special characters, 12 letters and numbers)
  • Realm: blank
  • SIP Servers:
  • Primary: (PBX IP), Port 5061 (chan_sip port)
  • Backup 1, 2 , 3: blank
  • Register: Checked
  • DNS SRV: Not Checked
  • Outbound Proxy: blank
  • Outbound Port: 5060 (didn’t change it since I’m not using a proxy)
  • SIP Port: 5061 (chan_sip port)
  • Idle Timeout (secs): 0
  • RTP Port: 20000
  • Max Call Timer (secs): 0
  • Night Ring: Not Checked
  • Pre-Announce Tone: Checked
  • Store and Play: Not Checked

Other settings that may be of interest:

  • Continuous Beacon: Checked
  • Audio Output Volume: -15

I appreciate any feedback anyone can provide!

Stumbled upon this as I was having the same issue.

I also figured out the long password issue.

I also had to go under the extension->advanced and change qualify to no.

I think it has to do with the Valcom Pager not being able to accept the OPTIONS packet makes it UNREACHABLE.

After doing that and running sip show peers in the CLI the pager extension just says unmonitored.

fyi, i just set up a valcom 204a (pretty much the same as the 201) i used pjsip extensions and had no issue. i used all defaults except the password, you have to make that short. but otherwise all defaults and it works well…

1 Like

I’m not sure If I’m still allowed to reply to this topic but I have the exact same setup and I cannot get it to work. I tried both pjsip and chansip for extensions. Is there anything in the newer versions of FreePBX/asterisk?