v2.3.1 just WONT install

ARRGH this is driving me CRAZY!

We have a Trixbox running Freepbx 2.2.3 perfectly happily
I have upgraded the Trixbox to the latest version using Yum.

Yum says its installed, yet it hasnt I still have 2.2.3 not 2.3.1

If I go to /usr/src/freepbx-2.3.1/ and run install_amp manually nothing happens!! it just sits there!!

I have tried --debug, and --force-version and yet I still cant get a response.
Tried rebooting several times both before and after an install, but again nothing.
Tried removing using yum and re-installing , but no joy
Also checked all the file permissions in /etc/asterisk and /var/www/html/admin and there doesnt appear to be any reason why the files cannot be written.

This is driving me absolutely crazy - I just CANNOT get 2.3.1 installed, no matter what I do !!


Ok don’t ask why (and I don’t understand it as I upgraded from 2.2.3 withotu a issue) but it has been reported that there is something strange with the RPM in trixbox for freepbx 2.3.1 for some users.

It has been said that if you reboot the box twice (let it come up and start to work for a minute or so in between) freepbx does get installed after doing the yum update that seems to not work.

Give it a shot.

As I previously stated - I have already rebooted the box several times!

When you are attempting to install using install_amp. Which user are you doing it as? Can you paste the output here.

the owner and group for /var/www/html and /etc/asterisk and everything under should be asterisk:asterisk

I am running install_amp as root
When I run it, nothing happens at all - there is no output to paste here!
Its definitely stuck as I have to ctrl-c to get back to a prompt

All files are set to asterisk.asterisk in both /etc/asterisk and /var/www/html/admin

Again, as stated before I have already checked all of these things !!!

yes you have stated things but what you mean and what others mean or what I expect can be different. I’m just a user trying to help. So here is goes…

Have you customized anything? changes amp passwords, any adjustments to PHP, etc?

What version of php do you have installed? type php --version and it will tell you.

If you do ./install_amp --help do you get any output. This will determine if it has gotten to a specific point in the code or not.

You said you ran it with --force-version If so it should echo’d a line out starting with "Forcing upgrade from version " Did you get that?

You said you ran with --debug. So if is saw that it should have generated a debug file. So let’s see what is says.

Within the first 8 lines of executable code it should output this line
Checking for PEAR DB…OK

If you don’t get that, then something is wrong with the PHP setup on the box somehow. I’m not a PHP geek so can’t help much at that point.

If I run --force-version or --debug I get no output whatsoever it just sits there.
However, I have now managed to get the script to run by forcing the version back to 2.2.0beta1

I couldnt run install_amp from any other version - I had 2.2.3 installed, but had to force it to 2.2.0 !