V15 Intrusion Detection - Unable to add IP address to whitelist

sysadmin
Tags: #<Tag:0x00007f70299b8a20>

#1

I got an IP address which keeps getting banned and need to whitelist it. As soon as I try to add the address into the Whitelist field box, it turns red, and the “Save Intrusion Detection” becomes unable to click.

I have even tried removing one IP address then adding the one I need, but it still turns red.

Any ideas?


(Mvogel4949) #2

Same here. Can we only change this through the Firewall module now?


(Mvogel4949) #3

I wonder if the red is because it doesn’t like the format of the IP address


#4

I tried it on a second FreePBX 15 server and it only has 127.0.0.0 in it. As soon as I move the cursor in the text area, it places it at the end of it. I have to press space to move over to type in a new IP address. As soon as I do that, the text box turns red.


(Lorne Gaetz) #5

It looks like the input validation for Whitelist when using the legacy setup is very picky. You must have one IP address per line, and IPv4 must be in a format:

x.x.x.x
x.x.x.x/xx

No spaces are permitted. When the box turns red indicating an error, you can continue typing until it’s fixed.


Cant add addresses to whitelist
#6

Oh, that explains things. It was changed then. The legacy one has it all on one line (even after it has been updated), and that is what I was trying to do. Maybe a tooltip would help with that with others.

Thanks!