V15 Backup: Exclude Voicemail wav files from backup but keep voicemail settings


#1

Is there a way to exclude the voicemail audio files from a backup but retain the voicemail settings? We incremental archive voicemail as it is created and deleted to cut down on bandwidth consumption. However, I found that if I exclude the voicemail module from the backup, the voicemail settings are not backed up. Things like whether or not a voicemail is active for a particular extension get lost. It would be great if we could exclude just the /var/spool/asterisk/voicemail folder from a backup. Is this possible?


(Lorne Gaetz) #2

Sort of. All of the vm config is stored in the text file /etc/asterisk/voicemail.conf so you could just back that single file up instead of using the module selector.


(TheWebMachine Networks (Sangoma Software Development Partner)) #3

As an aside, I do miss the Exclude filters in the old Backup. Perhaps there is a way to bring them back? Granted, with the way v15 Backup works, I’m guessing this would need done on a module-by-module basis?

Manually adding the voicemail.conf file is totally cool for the VM module in this scenario, but the Custom Files list could get unwieldy if you tried this approach with some other modules without an explicit exclude available. (Just thinking out loud. :smirk:)


#4

Thank you!


#5

@lgaetz backing up voicemail.conf (while de-selecting the voicemail module) doesn’t seem to work. All voicemail boxes on the warm spare are disabled, just as they were when I just deselected the voicemail module.


(Lorne Gaetz) #6

I’ll take your word for it. I think this is something that will need a feature request. It may not get immediate action as I would expect that most admins will want to backup both vm config and audio or neither. You can file a feature request at https://issues.freepbx.org/


#7

Update: It actually does seem to work after all. The warm spare’s voicemail settings hadn’t been backed up and were in a bad state (all extension’s voicemail disabled) when I ran the backup that included voicemail.conf. I ran another backup that included the voicemail module, then I created a new extension w/ voicemail enabled on the primary and ran a backup that didn’t include the voicemail module but did include voicemail.conf. The new extension showed up on the warm spare with voicemail enabled.