V13 backup -> v16 Restore troubles

On a fresh install of FreePBX 16, I restored a backup from v13. Now, things are broken.

None of my extensions can dial anything. Calls fail with:
NOTICE: res_pjsip_session.c:4027 new_invite: 300: Call (UDP:w.x.y.z:58140) to extension '306' rejected because extension not found in context 'from-internal'.
But all extensions are in ‘from-internal’.

Looking at the dialplan commands, it looks like nearly all of the contexts are missing:
pbx1*CLI> dialplan show 300@from-internal
There is no existence of ‘from-internal’ context
Command ‘dialplan show 300@from-internal’ failed.

pbx1*CLI> dialplan show
[ Context ‘parkedcalls’ created by ‘res_parking’ ]
‘80’ => 1. Park() [res_parking]
‘81’ => 1. ParkedCall(default,81) [res_parking/default]
‘82’ => 1. ParkedCall(default,82) [res_parking/default]
‘83’ => 1. ParkedCall(default,83) [res_parking/default]
‘84’ => 1. ParkedCall(default,84) [res_parking/default]
‘85’ => 1. ParkedCall(default,85) [res_parking/default]
‘86’ => 1. ParkedCall(default,86) [res_parking/default]
‘87’ => 1. ParkedCall(default,87) [res_parking/default]
‘88’ => 1. ParkedCall(default,88) [res_parking/default]

[ Context ‘func_periodic_hook_context’ created by ‘func_periodic_hook’ ]
‘beep’ (CID match ‘’) => 1. Answer() [func_periodic_hook]
2. Playback(beep) [func_periodic_hook]
‘hook’ (CID match ‘’) => 1. Set(EncodedChannel=${CUT(HOOK_CHANNEL,-,1-2)}) [func_periodic_hook]
2. Set(GROUP_NAME=${EncodedChannel}${HOOK_ID}) [func_periodic_hook]
3. Set(GROUP(periodic-hook)=${GROUP_NAME}) [func_periodic_hook]
4. ExecIf($[${GROUP_COUNT(${GROUP_NAME}@periodic-hook)} > 1]?Hangup()) [func_periodic_hook]
5. Set(ChannelToSpy=${URIDECODE(${EncodedChannel})}) [func_periodic_hook]
6. ChanSpy(${ChannelToSpy},qEB) [func_periodic_hook]

-= 11 extensions (17 priorities) in 2 contexts. =-

However, from-internal is listed in every “extensions” file in /etc/asterisk. This appears to be the case for my trunk contexts as well, but I’ve not tried any outbound calls yet since I cant even make internal extension to extension calls.

I have no idea why this would be. Restoring the backup produced no errors.

Any help would be appreciated.

I tried deleting all extensions files and doing a “fwconsole reload” to rebuild them all, but that didn’t fix it.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.