User Manager AD Auth Cannot Sign In

I’ve got two separate FreePBX installations that I’ve switched over to AD authentication for our User Manager accounts.

Details on servers…

Server 1:
FreePBX 13.0.187
Asterisk version 11.15.0
All installed modules are up to date

Server 2:
FreePBX 13.0.187
Asterisk version: 13.9.1
All installed modules are up to date

Both User Management versions are 13.0.72

My problem is that the AD Auth interface says ‘Connected’ and is properly pulling in users and groups into the User Manager, but it is not allowing those folks to sign in. Any attempt at signing in, on both servers, and for any user, is met with the error “Invalid Login Credentials.”

Our domain environment is currently Windows Server 2008 R2. I’ve seen in other comments that folks have been able to get this working properly in a 2012 environment so maybe that has something to do with it?

Any help would be greatly appreciated.

try to have them sign is like so:

[email protected]

No dice. I’ve tried multiple ways:

domain\username
domain.com\username
[email protected]
[email protected]

I’ve tried using the following in the configuration screen, both say connected but don’t work to login:

domain
domain.com

Tried using both OU= and CN= in the Base DN: OU=Users,OU=Region,OU=Company,DC=DOMAIN,DC=COM

Tried using a domain administrator account instead of a standard domain user as the helper account. No help there either.

Argh, I’m an idiot.

I did not have the group set to Allow Login under UCP -> General

Problem solved. Sorry for wasting your time on a stupid issue!

1 Like

It helped me, thanks for posting the solution!