User Management > UCP Settings Don't Save

I am trying to configure users and groups through User Management. I created a number of users and a few groups the other day, and set them with the ability to access a few different shared extensions and mailboxes. Initially I had problems with the group settings applying, but finally tracked that issue down to ordering; they were all still set to a priority of 5. I reordered them, and now they work.

I am now having a different issue, and I can’t say for sure if it is related. I am no longer able to edit any settings related to UCP for either users or groups. I can make the changes and hit submit, but the changes do not become active, and if I go back to the UCP settings for that user or group, the settings have reverted. I also note that they all seem to revert to “no” or are blank.

Any thoughts on what is going on here, or how I can fix it?

i seem to remember an earlier issue that was since corrected - insure all modules are up to date and that permissions arent an issue …

[[email protected]] fwconsole ma upgradeall
then
[[email protected]] fwconsole chown

im unable to reproduce what you are seeing on an up to date system

According to Module Admin the modules are all up to date. I also tried the upgradeall and chown commands you recommended, but the problem persists.

I also note that the priorities on my current groups start at zero; I seem to recall that previously they started at 1. Maybe unrelated, but thought I would mention it.

You need to install the beta version of user manager

Thanks. It looks like the stable version that just went live also fixes the issue (at least, the settings changes appear to persist).

Yes it does. It was tested by a few people before going live.

Problem still persists here after downgrading the User Management module to beta v13.0.40 and all other modules are up to date. I am syncing through Active Directory.

When updating to latest stable and try to make a change, I get PHP and SQL errors:

PDOException thrown with message "SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'uid' cannot be null"

## Stacktrace:
## #11 PDOException in /var/www/html/admin/modules/userman/Userman.class.php:1543
## #10 PDOStatement:execute in /var/www/html/admin/modules/userman/Userman.class.php:1543
## #9 FreePBX\modules\Userman:setModuleSettingByID in /var/www/html/admin/modules/contactmanager/Contactmanager.class.php:623
## #8 FreePBX\modules\Contactmanager:usermanUpdateUser in <#unknown>:0
## #7 call_user_func_array in /var/www/html/admin/libraries/BMO/Hooks.class.php:186
## #6 FreePBX\Hooks:processHooksByClassMethod in /var/www/html/admin/modules/userman/functions.inc/auth/Auth.php:31
## #5 FreePBX\modules\Userman\Auth\Auth:updateUserHook in /var/www/html/admin/modules/userman/functions.inc/auth/modules/Msad.php:306
## #4 FreePBX\modules\Userman\Auth\Msad:updateUser in /var/www/html/admin/modules/userman/Userman.class.php:1106
## #3 FreePBX\modules\Userman:updateUser in /var/www/html/admin/modules/userman/Userman.class.php:296
## #2 FreePBX\modules\Userman:doConfigPageInit in /var/www/html/admin/libraries/BMO/GuiHooks.class.php:290
## #1 FreePBX\GuiHooks:doBMOConfigPage in /var/www/html/admin/libraries/BMO/GuiHooks.class.php:252
## #0 FreePBX\GuiHooks:doConfigPageInits in /var/www/html/admin/config.php:340

I am running FreePBX v13.0.35.

Fixed in userman v13.0.43

It works now on the latest versions! Thanks!

Correction on my FreePBX version. Its now showing v13.0.36 since my update today.

I’m having this issue now with 13.0.76.27 on Distro 13 authing against AD
I’m not sure at what point it broke but it used to work up to a few months ago.

There are multiple issues in this thread. Please do some troubleshooting and post the error here.