User Management - Inherited value source

Hi all.

Set up a bunch of users with the Bulk Handler. Set passwords, usernames, attached extensions, worked great. However, none of the users can log in.

So I changed the user management setting for a user in the UCP configuration tab, under General, called ‘Allow Login’ to ‘Yes.’ It worked, great!

However, every user is set to “inherit” by default, and there’s no bulk handler option or mass configuration option that I can see to change this value for all users. Also, I cannot find in the documentation or interface where the user inherits this from. Doesn’t seem to be in the groups, in the advanced settings…looked around in the user management configuration area and couldn’t find a default for this that the users could inherit from.

I need to change this for a bunch of users. I’m hoping someone can point me to an option to set to ‘yes’ for all users, or how to change the inherited setting to ‘yes’ so they all just pick it up without needing the adjustment. How can I do this, as the bulk handler does not have this as a column I can send through for mass configuration…

As an aside, why is the inherited value ‘no’ to begin with? I understand this makes more sense from a security point of view, but setting strong passwords automatically is usually enough.

This inherits from the group the user is assigned to with the highest priority.

Yup, that’s exactly where that is. I feel blind.

I had made another group called ‘managers’ that I wanted to have a higher priority. Dragging and dropping the groups on the main page let me adjust that priority so ‘all users’ and ‘managers’ didn’t have the same priority.

Also, not sure how it happened, but I think my ‘all users’ group got messed up somehow. By default, it looks like that user group has no extensions. When I manually added all the users into the ‘all users’ group, I was able to log in. When I added a new user through the normal freepbx interface, it selected the ‘all users’ group by default. I’m guessing I had problems because I added the users with the Bulk Handler, and there’s no way to set the group of the users when you bulk import them in.

Sounds like a feature request or a bug. Not sure which.

Feature request. (my opinion)

I concur! Thanks for your time Mr. Nagy!

1 Like