Use voicemail, but disallow people to record a message


I want to have the option for people to record a message for when they are unavailble.
Everyone can record something using the standard voicemail option (*97 en *98).
This works fine.

However, i don’t want any caller to record a voicemail message to the extensions.

Is there any way i can enable the voicemail greetings and allow people to record their own message, but stop people from recording the callers messages?

The company does not want to use recording of voicemail messages at all, so it can be turned of system-wide and not just for an extension.

Create an announcement. In the system recording associated with the announcement, enable the optional feature code. In extension setup at the bottom of the page, set the fail overs to access the announcement.

The announcement may be changed at will using the feature code.

Thanks, that sounds like a possible option. Though i have to edit every extension, existing and in the future.
Isn’t there a way by editting a config file? I’m not sure if this is possible, but i figure it’s like (ring, goto voicemail, play greeting, record message) somewhere in a config.

Not sure though, otherwise i didn’t have to ask here :slight_smile:

No, it’s nothing like that. The voicemail module is compiled C.

Anyway, have you tried setting max messages to 0? I would also remove the “voice mail box is full message”

Check Voicemail Admin module.

In the future always include Asterisk/FreePBX version and the installation environment.

I tried this and it seemed to work OK.

  1. In Voicemail Admin Dial Plan Behavior set Disable Standard Prompt
  2. Go to settings and change maxmessage to 1. This causes the system to only allow a 1 second message.
  3. Have each person record their greetings.

When you call the extension and it goes to voicemail the greeting is played, you almost immediately hear a beep since the recorded voicemail can only be one second long. you then hear the system announcement “Thank You, Goodbye”

The only thing I don’t like about this solution is that the system announcement “Thank You, Goodbye” is played.

maxmessage will not take a 0 for a value.

Thanks for the possible sollutions.
It’s running Freepbx 4.211.64-9 with Asterisk 11.

I’ve checked and i can get a maxmessage time of 0.1, so that could work.
and if i replace the vm-goodbye (i think that is the correct one) with a silent vm-goodbye.gsm, i got that part covered aswell.

I’ll give this option a try and see if i can fix a silent vm-goodbye.gsm.
Deleting the .gsm sound file probably won’t be a good idea :slight_smile: