Use username instead of extension number

extensions
configuration
Tags: #<Tag:0x00007f4f4ba8e7c8> #<Tag:0x00007f4f4ba8e0c0>

(Christos Mitsis) #1

Hi, I have created my FreePBX on a Raspberry Pi 4. I have successfully added two extensions and a trunk for the outside world. I also managed to add a SIP Phone and a softphone to each extensions. I was wondering how could I use an alphanumeric username to connect to the PBX from the phones. Now I am using the extension number and the secret to connect. I am also using PJSIP. I have been searching the internet the past few days to find a solutions but I couldn’t find any answer. I only found that I need to change something in the configuration files but I don’t know what exactly. Can someone guide me?
Thanks in advance :grin:


(TheJames) #2

There is no “supported” way to do this.


(Christos Mitsis) #3

Is there any workaround that you know? It isn’t so important but it triggers my OCD :joy:. Besides, its very strange that FreePBX has all those capabilities but not assigning a username for an extension/endpoint


(Lorne Gaetz) #4

This was a design decision from the very early days of FreePBX, you can’t control the sip username, only the sip secret.


(TheJames) #5

Basically you can use Device and user mode to accomplish this. When D&U mode comes up it always turns in to some sort of holy war so I avoid the mention. The internal plumbing of FreePBX separates the concept of devices and users. The way the data is presented to and managed by the front end is as an “extension” which is a combination of a device and a user. When things happen within FreePBX they usually happen as an extension. Back in the day (way way way back) the ability to manage the user separately from the device was exposed. This ultimately gives you the ability to do what you are asking.

So can you? Yes. Should you? Well bring on the holy war!

Note that “not supported” and “doesn’t work” are not the same thing.

Using D&U mode can cause issues and break things. This is especially true if you don’t know what you are doing. That is why it is not now, not has it ever been “supported”. If you enter in to the valley of dragons nobody blinks when a dragon kills you.

I would say if you want to try, expect death by dragon :slight_smile: :dragon:

So back to my original short answer, there is no supported way to do this.


(Christos Mitsis) #6

This is actually a very good answer! Thank you very much. I suppose that I will not enter into the valley, but if I do, I will come back and post what I did so if anyone is also interested can have an idea.


#7

If you want people to be able to call you by name, put the name in the SIP Alias field in Advanced settings for your extension.

If you want your name to be displayed to the destination party when you make calls, fill in Display Name (applies to internal calls) and/or Outbound CID (applies to external calls) for your extension.

Note that in most countries, the name displayed to the external called party comes from a database, which your trunking provider should allow you to set.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.