Use To Be Able To Run FreePBX Parallel With ATA Adapter

I started out with an ATA adapter from a VoIP vendor for our residential service. I use to be able to run both the ATA device for standard phone while also using FreePBX to an IP phone. The VoIP provider allows up to four registrations and I can see on the providers portal that both, the ATA adapter and the FreePBX, are registered. The standard phone and the IP phone would ring with an incoming call and either phone could answer. The residential VoIP service allows two concurrent calls, so while the standard phone was in use, I could call out on the IP phone and all seemed well.

I’m not sure what I changed recently, but now when a call comes in, the standard phone on the ATA device may ring once (or half a ring) and then stop ringing, but the IP phone through FreePBX keeps ringing. I can answer the call on the IP phone.

Is there a setting in FreePBX that would cause this type of behavior? Maybe signal all other devices outside of its domain that it “has” the call and to disregard?

Most likely, the PBX is answering the call. To confirm, call in from your mobile but don’t answer the ATA or the IP phone. While you are hearing ringing, the mobile should be showing ‘dialing’ or ‘connecting’. If it shows connected and counting time, the PBX has signaled answer.

This could happen in the Inbound Route – make sure that both Detect Faxes and Force Answer are off.
It could also happen in the Extension, if you have Follow Me with an Announcement or Music on Hold.
Or, if the Inbound Route doesn’t go directly to the Extension, the intermediate app(s) could be picking up the call.

If you still have trouble, post a log of an incoming call.

Why do you have a PBX at all, rather than just registering the IP phone to the provider? And if the PBX is providing useful services, why not register the ATA as an extension on the PBX, so the analog phone can also benefit from those services?

Thanks for the reply and perspective. I didn’t think to check the status of the mobile during these conditions. After this happened, I disabled the trunk in FreePBX in order for the standard phone to work correctly. After reading your reply, I enabled that trunk again, but at the moment, both ATA and PBX are ringing on incoming calls. !! If it happens again, I will be sure to check the status.

The inbound route is not setup to Detect Faxes nor Force Answer. No Follow Me or MoH. Calls are routed to a ring group which is setup to ring more than 4 times before directing to a voicemail virtual extension. At the moment, I want the standard phone answering machine to receive the calls which picks up on the 4th ring.

I have the PBX because it peaks my interest and for it’s flexibility plus to obtain the knowledge for a possible work phone system replacement. After I determine that my PBX configuration (designed for home use) works consistantly, the plan is to have an ATA adapter attached to the PBX. At the moment, I like to have the ATA as a separate device that was supplied by the VoIP provider so if something doesn’t work, I can fall back on the provider to get me going in case the phone stops working. Less liability on my part as a IP-PBX computer doesn’t have to be running in order for the phone to ring.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.