Use Telco VM on POTS line

I have several SIP trunks and one POTS line. Is it possible to continue to use the Telco VM on the POTS line? In FreePBX, I have the ring time set to 60; the provider is at 5 rings (so more than enough). When I call the trunk, it never goes to the providers voicemail, as the provider shows the call as being “answered”. It seems Asterisk grabs the line from the ATA when it rings. When I was using 3CX, that didn’t seize the line until it was answered. The ATA isn’t configured differently.

I know there are a lot of features in Asterisk VM, and many will day I should just use that, but that is not what I am looking for…yet.

To summarize: I’m looking for a caller on our POTS line to be able to leave a message in the Telco voicemail assigned to that line when not answered.

If the inbound route goes to any destination that needs to answer the call, then then call will be answered, for example a queue or an IVR.

No IVR, VM, Announcement, Queue, etc. It goes to a ring group. Would that “answer” the call?

A ring group should not answer the call, unless fax detection is activated.

I don’t see anything that would cause it to answer…faxing is not enabled anywhere (it’s easier to do an ATA to the fax machine).

I’ll try a few test calls tomorrow and see if the FPBX and ATA logs can show me anything more.

On the advanced tab of the inbound route make sure that forced answer is set to no and in the ring group make sure the announcement is set to none. Those are two things that could make it marked as answered.

I have to ask though, why the Telco VM? How do you get notified of messages since you never really hear the Telcos dial tone in FreePBX? (Not trying to challenge you on this, I’m genuinely curious.)

Hi @nortelvoip,
Yep, checked those - not the problem. In troubleshooting today, the ATA is definitly showing that the call is being “answered” within one ring. To troubleshoot, changed the IP of FPBX in the ATA and the ATA did not answer, not did it when I set the ATA to route to the FXS port, leading me to believe it is FPBX “answering” the call.

I’ve uploaded my FPBX logs from a test call. Nothing glaring at me, but I’m definitly not an expert at interpreting SIP logs.

FPBX Log.tgz (3.8 KB)

@nortelvoip - to answer your question on “why”, the provider’s email sends notifications with spech-to-text. I haven’t committed to FPBX enough (I’m a hobbyist), to spend the $25 yet for SysAdmin Pro to enable e-mail notifications yet.

With that aside, I just did a test by sending the inbound route to an extension, not the ring group. For the purpose of the last test noted above (with the logs attached), I made the ring group send to one extension -184 - an Avaya 9611. For this test I made the extension the inbound route rings - 184. This time, the line was not seized by FPBX while ringing and the call wen to the proper VM.

Here’s my Ring Group settings:


[2020-07-07 12:50:51] VERBOSE[6873][C-0000004c] pbx.c: Executing [[email protected]:2] PlayTones("PJSIP/anonymous-0000009f", "ring") in new stack
[2020-07-07 12:50:51] VERBOSE[6873][C-0000004c] pbx.c: Executing [[email protected]:3] Progress("PJSIP/anonymous-0000009f", "") in new stack

So the Ring Group with default settings is playing ringback tone in early media, which most ATAs would ignore with their defaults, but yours appears to be answering the call to play what Asterisk is sending.

In the Ring Group, try setting Send Progress to No. If no luck, try also setting Play Music On Hold to None. If still no luck, post ATA make/model and configuration details. (If you use the same Ring Group with SIP DIDs, test that the change doesn’t affect incoming SIP calls.)

Probably unrelated to your present problem, the incoming call appears ‘anonymous’ (it’s not recognized as related to the trunk you defined). How is the pjsip trunk set up (statically, registration receive)?

1 Like

Thanks @Stewart1! Setting SendProgress=No did the trick.

The "anonymous’ issue I’ve had for a bit and can’t seem to figure out. I’ve got another thread open on that, so please do take a look and let me know your thoughts.

You don’t need to buy sysadmin pro to get email notifications.

Correct, you don’t need sysadmin pro to get email notifications, however, FreePBX does not have a way to transcribe voicemails out of the box. But it can attach the vm to the email notification.

Glad you found what was causing the problem.

I should prob start another thread for this, but how do I enable email notifications? I’ve been looking into the transcriptions, but figured they would be useless without the ability to send notifications.

I’m a hobbyist as well, though I have to admit that I did shell out the $25 for Sysadmin pro. (It was worth the added ease of configuration IMO.)

It’s been a while since I have configured SMTP settings but you have to configure postfix.

Here is a link that may help you.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.