Use Digium phone from home?


(Kombi1) #1

Digium handset registers fine from home but can’t make calls. The sip trunk provider’s name even shows up, yet next to a yellow triangle warning sign.

/var/log/asterisk/dpma gives me “No auth credentials found in phone msg”. Under Connectivity / Digium Phones / Global Settings / Phone Authentication Method I tried “Phone MAC Address”, “Phone Pin” and “Global Pin” but to no avail. How do I teach the phone credentials?

On CLI, digium_phones show phone [id] states "Login Password ‘not set’ ". How / Where do I set that?

(A Softphone using the same connection works perfectly, so no firewall issue)

Stay healthy,
Konrad


(Dave Burgess) #2

Let us know what the configuration of the phone looks like, specifically, where is the phone trying to connect? Is it direct to your ITSP, or are you connecting it to an Asterisk server?


(Kombi1) #3

I solved that one: Simply forgot to add an entry in “External LInes” in the DPMA web interface in FreePBX (stupid me!)

Now trying to figure out how to make contacts and blf work over port 443. If someone had an idea how to “teach” the phone an URL and a port for contacts and BLF, I’d be very interested!

Cheers and everyone stay healthy,
Konrad


(Malcolm Davenport) #4

Networks -> File URL Prefix.

Note that the phones validate the SSL certificate by default, so if the SSL cert is self-signed, the connections from the phone will fail. You’ll have to go to each phone and turn on “Enable Dangerous Unsigned SSL Certificates” from the phones’ boot menus to allow them to not validate the SSL certificates.


(Kombi1) #5

Dear Malcolm,
I get stuck “Loading Favorites”, regardless of “Enable Dangerous Unsigned SSL Certificates” on or off.

Should I rather copy the ssl cert over to the machine getting the request?

Other things I tried in vain:

  • configure the webserver to serve the xml on port 80 and set File URL Prefix to http
  • get the phone to log to rsyslog with settings in Networks

Cheers,
Konrad


(Malcolm Davenport) #6

If the phone’s logging to a remote syslog server (the D80 doesn’t support this) you should see noise in there about it trying to download the contacts file…it should indicate where it’s trying to download it from and what it’s trying to download and the results of that. I can’t be depended on to provide support; I’m not reliable due to many commitments.


(Kombi1) #7

Thanks & no worries, stay healthy!


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.