USB GSM Modem as a trunk

Hey all,

I’ve seen that Asterisk supports chan_dongle ( for using a Huawei usb gsm datacard as a GSM/SMS gateway.

I wonder if anybody is using this with freepbx, and if it works.

Just in case it is compatible, I just wonder how to configure the dongle as a trunk via the Freepbx GUI (Custom trunk? If yes, with what custom dialcodes?).

Thanks in advance for any help



I am currently using two. It is possible to use more. Of course, it can come to a point where it would be a lot easier on management and maintenance, and maybe cheaper to use sim-banks and networked gsm modems.

I Guess the title says it all, is it possible to setup 2 dongles?

Thanks for your reply KenPark, I’m trying to setup two sim cards that are both forwarded to the IVR, but i also want them to talk to each other, say someone calls me on number 1, i want the ivr to answer and send the call to number 2 along with the other extensions i have setup. also I would like to setup DISA to be able to call from the other line once. is this setup possible, I’ve got two gsm dongles laying around and i would love to try that setup.


I have 2 Dongles connected to my Raspbx via a powered USB hub, a fully functional E169 Huwawei and the other one is a newer E180, both connected as dongle0 and dongle3 i can text from them both sending and receiving, the only issue im having is with dongle0 (E180) i cannot receive calls, asterisk -rvvvvv returns the following when i call it:

[2013-06-20 19:03:52] WARNING[8426]: at_response.c:1207 at_response_cmgr: [dongle0] Error parsing incoming message '+CMGR: 0,,140 07916965854771F92406D057E4134108316002913094217C0059006F0075002000680061007600650020006D00690073007300650064003A0031002000630061006C006C002000660072006F006D0020002B00390036003500390039003000350030003300380035002000610074002000310039003A003000330020006F006E00200036002F00320030002F003100330020000A' at possition 45: Unhandled PID value, only SMS supported

I dont know whats causing the issue, according to E180 is supported so what am i doing wrong?

Hi Carlo!
Chan_dongle works with freepbx, you will need install asterisk-addons, asterisk-devel, get source of current freepbx asterisk release ( and compile chan_dongle,

Usage is via custom trunk: dongle/dongle0/$OUTNUM$

I forgot to mention, you will need change context in dongle.conf from “default” to “from-trunk”

could you tell me how to route GSM trunk to IVR?

thank you in advance.

exten => s,1,Goto(from-trunk,${DID},1)

but keypress not responding.

Thanks, Matapaca!
I’m gonna try it as soon as I get proper dongle from ebay!
Thank you very much


Hi Mapataca,

Really pleased that you got Chan_dongle to work for you !!!

I tried installing it after untaring (chan_dongle-1.1.r10.tgz) on my system built from the AsteriskNow2.0 iso file package which uses linux centOs 5, but I just couldn’t get the dongle to work!

I configured & installed the package with:

./configure --with-asterisk=/usr/include


make install

Note that the location for “asterisk.h” is “/usr/include” on my AsteriskNow2.0 install.

Then copied the dongle.conf file to “/etc/asterisk/”

Unfortunately, when I check for devices in “/dev/” there is no ttyUSB1 or ttyUSB0 !!

I even tried commenting out the lines in dongle.conf for “;audio=dev/ttyUSB1” & “;data=dev/ttyUSB0” and instead entered the correct 15-digit imei & imsi numbers for my unlocked huawei E1550 from the “Etisalat” mobile provider.

But still no device shows up when I run “*CLI> dongle show devices”.

Could you please help me on where I went wrong?

Since you have your dongle up and running I’m sure I can’t go wrong with your help !!

Thank you in advance.

Awaiting your reply.

Dear All
please let me know if i want chan_dongle for DISA purpose in freePbx then how and where to but this chan_dongle device and how much cost for this.