Urgent problem on production server

Hello all !

Suddenly (I was doing some modification on FreePBX I get the following error when doing the application of the changes :

exit: 255Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf …OK
Bootstrapping /etc/amportal.conf …OK
Parsing /etc/amportal.conf …OK
Parsing /etc/asterisk/asterisk.conf …OK
Connecting to database…OK
Connecting to Asterisk manager interface…OK
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asteriskAdded to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = elastix456
PHP Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 39 bytes) in /var/www/html/admin/extensions.class.php on line 63
1 error(s) occured, you should view the notification log on the dashboard or main screen to check for more details

I do not remember which change caused this problem. Could you help me to understand where I have to correct things?

Thanks you very much for any quick help as this is a production server and none of my changes are taken into account …


PS Here is what I find on the dashboard :
Reload failed because retrieve_conf encountered an error: 255

Post edited by: fabianus, at: 2008/07/23 22:27

It looks like you need to increase the memory limit in php.ini

Edit /etc/php.ini with whatever you prefer & find memory_limit (it’s 314 lines in on my system).

The advised size with the latest Freepbx is 100M as opposed to the default of 8 or 16M with the basic PHP install.

Dear rjenkinsgb !

Thank you very much for your quick support !

This solved it.