Urgent help needed: Can't access Web GUI at all!

Hey everyone. This is sort of an Elastix question but I really only use FreePBX from my install and I think it’s a generic problem with my asterisk system:

Here’s my problem. I have Elastix 2.0 and I needed to move it to a new server. I updated everything, yum update, yum update elastix, latest version of FreePBX etc. I then ran the Elastix backup.

I downloaded the latest version of Elastix from the website here, installed it and did the same, updated everything to the latest version then I restored the backup. Everything worked immediately, except phones couldn’t call each other it would go to voicemail. Rebooted the system and everything works exactly the same no issues at all.

That was 2 days ago. This morning I accessed the Elastix admin page, it let me log in and brought me to the main page. However clicking PBX just shows a blank page. Going to http://asteriskip/admin says:

FATAL ERROR

DB Error: connect failed

Trace Back

Array
(
[0] => Array
(
[file] => /var/www/html/admin/common/db_connect.php
[line] => 69
[function] => die_freepbx
[args] => Array
(
[0] => DB Error: connect failed
)

    )

[1] => Array
    (
        [file] => /var/www/html/admin/header.php
        [line] => 131
        [args] => Array
            (
                [0] => /var/www/html/admin/common/db_connect.php
            )

        [function] => require_once
    )

[2] => Array
    (
        [file] => /var/www/html/admin/config.php
        [line] => 54
        [args] => Array
            (
                [0] => /var/www/html/admin/header.php
            )

        [function] => include
    )

I rebooted a few times, now going to the Elastix login page it’s just blank right off the bat. If I run amportal restart it says:

[[email protected] asterisk]# amportal restart

STOPPING ASTERISK

Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

Asterisk Stopped

STOPPING FOP SERVER
FOP Server Stopped
SETTING FILE PERMISSIONS
Permissions OK

STARTING ASTERISK
Asterisk Started

STARTING FOP SERVER
FOP Server Started

The file asterisk.ctl does exist so no sure but it’s empty if that means anything. The phones all work and there’s no issues but I can’t access FreePBX or Elastix. I read somewhere the latest ISO from Elastix seems to have this as a bug so not sure what to do. I can’t really wipe it and start from scratch as I did the migration over the weekend and now my users will need access to their phones during the week. Is there anything I can check? Elastix just shows a blank page but FreePBX shows that error above. Also that error when doing amportal restart seems to show something in general with asterisk. Thanks so much.

I had the same problem after doing a ‘yum update’ on my elastix 2.0 box.

I dug around a little, and found that PEAR got screwed up by it.

Open a shell up, then type pear list. You should see

If you don’t have it, type pear channel-update pear.php.net, followed by pear install DB. This fixed the problem for me.

Edit: Punctuation helps. :smiley:

Did you use special characters like a # or & in the MySQL password or elastix admin password when you set up the new system? If you did it will mess up the FreePBX GUI and the PBX portion of the Elastix GUI.

Unfortunately I found this out the hard way too, The setup will let you use those characters when you set up a password and does not warn you about it. I reinstalled to fix the problem but there may be a way to fix it without reinstalling. I am just not sure how. If you find out let me know.

-Brandon

Thank you very much this solve my error

login to the console using putty or any other ssh client. then just run this command and that will put the default palosanto password back. then change it and make sure not to use special characters.

sqlite3 /var/www/db/acl.db “update acl_user set md5_password=‘7a5210c173ea40c03205a5de7dcd4cb0’ where id=1”