FreePBX | Register | Issues | Wiki | Portal | Support

Upgrading to New System


(BGM) #1

We are running FreePBX 12, and I want to upgrade to 14. I would follow this guide to migrate everything, but my problem is that since the new FreePBX is not activated, I have no access to System Administration in the new system. How can I make sure the new system is configured when I don’t have access to any of the commercial modules, nor to the system’s own configuration through the FreePBX interface?

I hate to think that I would have to buy a second license to activate the system just for the time needed to migrate everything. I need to have both systems running correctly in order to configure the new one before moving from my production server to the new server.

The docs for the Conversion Tool says: “The conversion tool requires that the new machine is Activated.” Do I really have to purchase a second license to do this?

Has anyone else had this problem? What do you do?


(Andrew Nagy) #2

Hi brother Gabriel!

Long time no see. Please open a free ticket up and see if they can help you. Alternatively because in the past you dedicated your own time and resources to better the community I can also help move your deployment to the new server. So message me if the ticket doesn’t work out


(BGM) #3

Hi, Andrew! Wow, I didn’t know you were still around!
I would absolutely love some help here. I’m afraid to mess things up. Samot is telling me a hoard of things in the IRC chat, but I’d feel much better having some non-chat help. Okay, I’ll place the ticket. Actually, the only reason I haven’t contributed anything else (like bug reports, etc.) is because my system is still on version 12, and nobody cares about that anymore. haha.
How do I go about placing the ticket? Do I do that through my FreePBX interface?


(Tom Ray) #4

I think we just covered this in the IRC channel, no?


(BGM) #5

We did, it’s true. But I doubt myself, and I’ll probably miss something. Samot actually did a great job explaining it to me. Of course, I guess I’m hoping for someone to babysit me over the phone, I guess.


(Tom Ray) #6

It’s not that hard. It takes like an hour depending on how big your system is. Just keep in mind as the guide says anything custom will not move while this generally covers the _custom.conf files this may also do the sound files because they end up in a /custom subfolder so just double check your uploaded sound files to see if they moved.


(BGM) #7

My last hangup is that I won’t be able to pre-configure the commercial modules due to their not having licenses on the new machine until I move the deployment ID. That means that I’ll have to do that whilst my production system is down - which means I’ll be on a deadline to finish before the staff returns. I’m thinking alot here about System Admin settings, IVR and Paging Pro.


(Tom Ray) #8

I’m confused as to what you will need to configure. You are migrating everything over so that means all the configurations for your modules, commercial or free, will move with that. All you won’t be able to do is have them generate the configs or manage them in the GUI until they are licensed. Doesn’t matter if you buy a new one or move the old one. The configuration is still there.


(BGM) #9

Ah, okay! That helps. Alright, I’ll try it.


(Lorne Gaetz) #10

If you are using the conversion script to migrate settings, then take note of this thread:


(BGM) #11

The first link is the guide for the migration tool, which I just completed.
The second link - what is CDR? Do I need to copy that over?

I’ll take a good try at that second link to copy the other stuff. Thanks for that!


(Sentinel) #12

I have done a ton. Let me know if you have any issues. Don’t forget to export your endpoint to csv


(BGM) #13

I ran the script and it seemed to work fine except for this part; I presume I will just move these file manually. These lines are from the script output:

Directory /var/spool/asterisk/monitor? (1.67GB) [yN] y
Directory /var/spool/asterisk/voicemail? (576.58MB) [yN] y
Directory /tftpboot? (1.51GB) [yN] y

Creating encrypted backup for new machine. This may take some time.
Backing up the following:
du: cannot access `5': No such file or directory
du: cannot access `t': No such file or directory

Then for the post-migration part:
Following the directions here, I was able to import the first sql db (cdr.sql) just fine, but when I go to import the second one, I get this error:

[myuser@myserver ~]# mysql asteriskcdrdb < /var/bgm/cel.sql
ERROR 1054 (42S22) at line 24: Unknown column 'src' in 'field list'

That db is 4.5gb in size. What do I do now?


(Sentinel) #14

did you export them first on the previous PBX?


(BGM) #15

Yes, I followed the instructions just like it said. The only thing I changed was the location of the output and input directories. I get the db import error when I run the last import command. Here is what it said to do:

  1. Transfer of CDR Export / Import

OLD PBX:
mysqldump --skip-add-drop-table --no-create-db --no-create-info --complete-insert asteriskcdrdb cdr > cdr.sql
mysqldump --skip-add-drop-table --no-create-db --no-create-info --complete-insert asteriskcdrdb cel > cel.sql

Transfer the sql files to the new server (WinSCP, etc)

Run on new PBX:
mysql asteriskcdrdb < cdr.sql
mysql asteriskcdrdb < cel.sql


(Sentinel) #16

Can you confirm the files are there on the new and old? Use what I have exactly and it should work


(BGM) #17

The files - you mean the sql files? I just created the folders yesterday; and just dumped the sql files an hour or so ago. Everything is fresh. I’ve never done this before today.
The only thing I changed was this when I made them:

mysqldump --skip-add-drop-table --no-create-db --no-create-info --complete-insert asteriskcdrdb cdr > cdr.sql
mysqldump --skip-add-drop-table --no-create-db --no-create-info --complete-insert asteriskcdrdb cel > cel.sql

to

mysqldump --skip-add-drop-table --no-create-db --no-create-info --complete-insert asteriskcdrdb cdr > /var/myfolder/cdr.sql
mysqldump --skip-add-drop-table --no-create-db --no-create-info --complete-insert asteriskcdrdb cel > /var/myfolder/cel.sql

And this when I imported them:

mysql asteriskcdrdb < cdr.sql
mysql asteriskcdrdb < cel.sql

to

mysql asteriskcdrdb < /var/myfolder/cdr.sql
mysql asteriskcdrdb < /var/myfolder/cel.sql

I tried several times to import the second db, but it gives the same error every time. I’ll try and export it again, copy it and import it again. Maybe it will work better the second time?

Okay, I tried it all again, fresh, and have the same error.


(Rob Thomas) #18

That’s saying ‘Don’t create the tables’.

That’s saying ‘The tables don’t match’.

I’m unsure why someone would say NOT to create the tables. Just use mysqldump asteriskcrdb cel > cel.sql


(BGM) #19

Should I redo the cdr, too? Although, I’ve already imported it… The cdr db didn’t give any error, though.


(Rob Thomas) #20

No errors, no problems. Just do the CEL.