Upgrading issues no GUI

In our lab server I upgraded it to 6.12.65-13 using the upgrade-5.211.65-to-6.12.65-13.sh.
I logged into the GUI and everything looked fine except I didn’t see FreePBX 12 features.
So I then started the Upgrade to FreePBX 12 module.
After upgrading the Framework module and applying it all I get is a white screen.
The CLI seems fine.
After doing some research and trying to solve the issue myself I keep getting the following error message.
I have tried running multiple amportal commands.
[root@localhost ~]# amportal a ma upgrade dashboard

Fetching FreePBX settings with gen_amp_conf.php..

PHP Fatal error:  Uncaught exception 'Exception' with message 'Unable to locate the FreePBX BMO Class 'Userman'A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) amportal a ma install userman 2) amportal a ma enable userman' in /var/www/html/admin/libraries/BMO/Self_Helper.class.php:191
Stack trace:

#0 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(100): Self_Helper->loadObject('Userman')
#1 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(36): Self_Helper->autoLoad('Userman')
#2 /var/www/html/admin/modules/userman/functions.inc.php(7): Self_Helper->__get('Userman')
#3 /var/www/html/admin/modules/bria/functions.inc/userman_hooks.php(20): setup_userman()
#4 /var/www/html/admin/modules/bria/functions.inc.php(4): include_once('/var/www/html/a...')
#5 /var/www/html/admin/bootstrap.php(209): require_once('/var/www/html/a...')
#6 /etc/freepbx.conf(9): require_once('/var/www/html/a...')
#7 /var/lib/asterisk/bin/module_admin(15): include_once('/etc/freepbx.co...')
#8 {main}

  t in /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 191
1 Like
rm -Rf /var/www/html/admin/modules/bria

This is fixed now in the bria module. Which should fix this for other people as well. Sorry for the troubles.

That fixed it. Thank you very much.

1 Like