Upgrading HD in FreePBX 60 Appliance

I’m attempting to upgrade the SSD in a FreePBX 60 appliance and I’m having a bit of trouble.

The latest FreePBX distro (SNG7-PBX-64bit-1805-1) kernel panics upon bootup. It crashes on the snd_hdmi_lpe_audio module. It looks like to be related known bug with CentOS so I tried an older distribution.

I was able to install and bootup SNG7-PBX-64bit-1712-2 without a kernel panic.

However, now the network ports don’t function.

I didn’t think upgrading the SSD would be such a headache. Anyone else experience issues like this?


You can try following way for fixing Boot kernel panic. You can fix it.
you can Install or Upgrade the pbx package to 1805 or higher --> sangoma-pbx-1805-3.sng7.noarch
After install first action --> yum update -y && yum update sangoma-pbx

1 Like

Thanks, I’ll try that once I can get past no working network ports. I tried cloning the 120gb SSD that came with the FreePBX and restored that to a 500gb SSD and that also results in no functioning network ports.

am I running into a hardware limitation with the size of the new SSD?

I think you have wrong or corrupt iso image. Before start check md5 image file.
FreePBX don’t have any limitation on SSD or SATA drive.

md5sum matches, it shouldn’t be corrupt. I experience the same behavior with cloning the orignal 120gb SSD and restoring it on a 500gb SSD or with a new install onto the 500gb SSD.

I am wondering if it’s a limitation of the FreePBX 60 hardware, and not FreePBX as a distro itself.

No any Hardware limitation. After change to SSD your Appliance will be work fast then before.

Thanks for the confirmation. I tried the other network ports and port 1 works. Port 0 and 3 do not work with the 500gb SSD plugged in. Bizarre! Power related? I won’t question it… I’ll just use port 1.

Thanks for your time and attention!