FreePBX | Register | Issues | Wiki | Portal | Support

Upgrading from FreePBX 10.13.66 to SNG7


#1

Hey guys trying to do an upgrade from FreeBBX to SNG7.

This is the output of the error message. Thanks all :slight_smile:

[root@freepbx upgradescripts]# yum -y install http://package1.sangoma.net/distro-upgrade-1807-2.sng7.noarch.rpm
Loaded plugins: fastestmirror, versionlock
distro-upgrade-1807-2.sng7.noarch.rpm | 12 kB 00:00:00
Examining /var/tmp/yum-root-t5j0oQ/distro-upgrade-1807-2.sng7.noarch.rpm: distro-upgrade-1807-2.sng7.noarch
Marking /var/tmp/yum-root-t5j0oQ/distro-upgrade-1807-2.sng7.noarch.rpm to be installed
Resolving Dependencies
–> Running transaction check
β€”> Package distro-upgrade.noarch 0:1807-2.sng7 will be installed
–> Processing Dependency: schmooze-release for package: distro-upgrade-1807-2.sng7.noarch
Loading mirror speeds from cached hostfile
–> Running transaction check
β€”> Package schmooze-release.x86_64 0:6-6.el6.shmz66.3.4 will be installed
–> Processing Conflict: initscripts-9.49.41-1.el7.x86_64 conflicts redhat-release < 7.5-0.11
Removing schmooze-release.x86_64 0:6-6.el6.shmz66.3.4 - u due to obsoletes from installed sangoma-release-7-5.1805.02.el7.sangoma.x86_64
–> Restarting Dependency Resolution with new changes.
–> Running transaction check
β€”> Package schmooze-release.x86_64 0:6-6.el6.shmz66.3.4 will be installed
–> Processing Dependency: schmooze-release for package: distro-upgrade-1807-2.sng7.noarch
–> Finished Dependency Resolution
Error: Package: distro-upgrade-1807-2.sng7.noarch (/distro-upgrade-1807-2.sng7.noarch)
Requires: schmooze-release
Error: initscripts conflicts with schmooze-release-6-6.el6.shmz66.3.4.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@freepbx upgradescripts]#


(Tom Ray) #2

This is a distro based machine, right?


(Lorne Gaetz) #3

Are you attempting to upgrade a 32 bit install?


#4

Also, what hardware are you running or is this a VM? If a VM, what’s the hypervisor?


#5

That’s 64 isn’t it?
[root@freepbx ~]# uname -a
Linux freepbx.sangoma.local 3.10.0-862.9.1.el7.x86_64 #1 SMP Mon Jul 16 16:29:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


#6

No hypervisors, bare metal.


#7

Correct distro based!


(Wzkds) #8

Did you get this sorted out? I recall I had some supermicro servers that could not upgrade to SNG7.


(system) closed #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.