Upgrading from Free PBX 12 to 13


I am at a loss as to the correct way to upgrade. I understand there is a built in module available entitled “PBX Upgrader” but when I ran this, the version number was out of date when I checked the Schmooze version.

If there is a requirement to run the script updates as well as the PBX upgrader, please would you kindly clearly communicate the order that I must do the various stages of upgrading in.

Any pointers would be gratefully received.

Thanks :slight_smile:

Hope this helps


Or possibly this??


1 Like

Thanks for these links Frank, I have already read both of them. What doesn’t seem to be explained anywhere is whether the “PBX Upgrader” module in FreePBX 12 is actually an alternate to the scripts or whether it is used as well as the scripts. I have searched the web high and low. I did not have positive experiences last summer of upgrading via the scripts although I am fairly confident in how to do this.

I also do not have the paid system admin module.

If I do need to use both the PBX Upgrader and the scripts, what order please?


you do not need to use the Upgrader. just run the scripts. be sure to run them in order and don’t skip any. one other thing before upgrading, make sure any paid modules are on a current support agreement. if you are running the end point manager and you have not paid the maintanence fee, then don’t do the upgrade until you do.

1 Like

Bob, you are a Godsend, thanks for taking the time out to reply to this and my other message.

I was told that my version 12 installation is corrupted and so I cannot move to version 13 but it works absolutely fine when running version 12. Nobody could put their finger on what this “corruption” actually was. I ended up with Asterisk refusing to reconnect in the Free PBX GUI, all manner of red errors in terminal and the system kept on freezing when I attempted to upgrade to version 13.

There are no paid modules - not that I am a skinflint, I simply can’t afford them as my work is voluntary so no commercial complications.

Any ideas on the issues I might have been having will of course be gratefully received.

Thanks again.

why don’t you back up your v12, install a fresh version of v12 (make sure it is exactly the same level), then restore from your backup and try to upgrade to v13 from there.

1 Like

That’s a really good idea! - “They” who will remain nameless as flaming doesn’t help anybody told me it was my data that was corrupt but it’s certainly worth a try!

Please may I ask, when doing the upgrade scripts, do I need to restart my box after each one and do I also need to run the module admin update check before I do yet another script or is that all taken care of by the scripts anyway?

Thank you

i think best practices say to reboot after each script. often it is not necessary but we do it as a matter of habit. and no, you don not need to run the module admin. the upgrade script will do all that is required. but as i said, run the scripts in order. so if your v12 system is at 6.12.65-24 be sure to run all the scripts starting with 6.12.65-25.

another best practice, is to snapshot your machine before doing an upgrade. or if you are not running a hypervisor, then do a backup before each upgrade. that way if something goes wrong you have an easy way to getting back to a running system pretty quickly.

1 Like

Great advice there!

I work with a Hypervisor yes and I do have a backup in place. I’m going to run these in order (i’m just hoping the bugs are ironed out from when I last ran these scripts) and maybe that’s the answer.

Failing that, I will download an iso and migrate the data across and do exactly the same thing again. I will report back either way!

Does v13 take any more memory than v12 - just wondering if my configuration of the hypervisor might actually be more the issue!


we run most of our pbx’s with just 2gb of ram. on some of the larger systems, especially the ones that make heavy use of iSymphony, we run about double that memory and add a core or two. but 90% of our systems are running with just 2gb ram and have been doing so for the last four or five major distro releases. there was not any noticeable increase in memory usage moving from v12 to v13.

1 Like

Hi Bob,

So I have attempted to upgrade by both methods. Firstly, I made a backup and then attempted to upgrade my version 12. This failed at the second script, firstly with a db connection issue and then with an issue relating to fwconsole. I raised the issue with fwconsole and I was advised by the developers to do a freepbx13 upgrade from the GUI, not to re-run the first script of version 13 that I had already run and then continue with the scripts. Due to the virtual machine continually crashing, I could not get any further forward.

Next, I looked for an exact replica of the freepbx 12 version that I am currently running in order to migrate the data across. I could not find an exact replica (I found 65-12-30 rather than 65-12-31), I then did a restore but now I have a complaint about retrieveconf - I tried everything I could see online to resolve it but I can’t.


after you ran the 6.12.65-100 script that should have upgraded you from v12 to v13, were you able to successfully log into FreePBX?

what hypervisor are you running?

when you attempted the restore, did you first upgrade the system to .31? i assume your backup is .31? can you log into the gui after the restore?

You will make life with freePBX much happier if you invest $25 in the commercial SysAdmin module, which handles all your upgrades, email config and other handy functions with 1 click. It is the best $25 I have ever spent.

Hi Bob,

Yeah, the first thing I did was to upgrade through the scripts so I followed the list of updates. The backup, therefore would have been from the latest version of FreePBX 12.

I’ve lost what i’ve done to be honest. I just can’t remember, it’s a nightmare!

I’m running Proxmox and there seems to be serious issues with it running out of memory upon upgrading even though the memory that you mention is made available in the hypervisor and it is physically available.

Not sure where to go from here…

Thanks :slight_smile:

Raised a separate topic for 6.12.65-31 not being available in http://downloads.freepbxdistro.org/ISO/ at 6.12.65-31 not available in old version distro downloads for the purposes of backing up live install of FreePBX and installing a fresh copy of FreePBX with the backup made from the live system (Please see Bob’s post above suggesting this). I will report back once I receive an update on the other topic.

i prefer xen as a hypervisor. it is basically free with a support option. we have found it to be very stable and easy to work with. i would start with a fresh copy of the hypervisor (proxmax or xen or whatever you what to use) create a vm using the FreePBX 12 iso. upgrade the system to the same level as your back up, then restore the backup. this should at least get you back and running on a FreePBX 12 system.

Thanks for this Bob, the live system still works it’s just that I am still having trouble migrating onto 13 without errors :slight_smile:

what happens when you run the upgrade script? does it complete but you are unable to log in? or does it never complete?

Hi, I abandoned the previous attempt and started again.

This time round, after spending the last 5 hours trying to get this to work I did the following:

a) Installed a fresh version of FreePBX - 6.12.65-30 on a new virtual machine with between 0.5 and 3.0gb of memory available and 300gb of hard drive space.

b) ran the -31 upgrade script on the fresh FreePBX Copy.

c) Backed up the data on the live FreePBX machine (running -31) and restored the data to the fresh freepbx copy.

d) checked for any updates through the GUI and restarted the fresh vm;

e) Ran upgrade-10.13.66-1.sh - it crashed with serious memory complaints appearing on the vm virtual screen available in Proxmox - audit: backlog limit exceeded - other errors included:

i) Out of memory kill process 12724 (asterisk) score 11 or sacrifice child
killed process 12724, UID 499 (asterisk) total vm:1354340kb, anon-rss:12308kb, file-rss:320kb

ii) Out of memory kill process 11767, (mysqld) score 8 or sacrifice child
killed process 11767, UID 27 (mysqld) total-vm:749756kb, anon-rss:3916kb, file-rss:40kb.

Eventually I got - [PDOException]
SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

This attempt never completed. It just got stuck.


sounds like a proxmox issue. try it with xen if you have a separate machine.