Upgrading Asterisk to specific version


I am about to retire my old PIAF asterisk server in favor of FreePBX. I downloaded the ISO, installed it to a freshly recovered Dell SC1425 (x64) with 16gb ram and a 250 gig sata drive. The install was successful, everything boots well, I defined a couple extensions as a test, and connected to my old Cisco SPA8800 4+4 telco device. Sweet.

The version of asterisk that gets installed is 13.14.0. For my purposes, I need to upgrade that to 13.15.0 specifically, and also patch it with “usercallmanager” from this website: usecallmanager.nz/patching-asterisk.html

The reason for this is I have a plethora of Cisco 9971 phones I’d like to roll out and unfortunately installing the above patch is necessary to enable more functionality of the phones.

So, thinking I was clever, I downloaded the 13.15.0 tarball into /var/src, untarred it, patched it, then compiled it for x64 then installed it. That worked flawlessly however freepbx is now “broken”. Whether asterisk is running or not, the FreePBX UI can’t find asterisk, doesn’t have permission to various things, and blows up.

Obviously that’s not the way to ugprade asterisk.

I then started from scratch on the same hardware following these instructions: wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+CentOS+6 to a “tee” except for adding the above patch right after untarring the asterisk tarball.

The instructions worked flawlessly and after the final reboot, FreePBX UI worked fine except about 90% of the menu options that are available after installing from the ISO, aren’t there. For example, the “Applications” tab/hover at the top only has four choices, including extensions, misc destinations, and two others. The rest of the menu options that come with the iso install aren’t there. The same for the other tabs/hovers.

So, I know I did something wrong in both cases, and I’m hoping for a little assistance and some basic instructions on how to solve this.

I am happy upgrading just the asterisk for the full ISO install, or building from scratch, whichever is best. I just need to use 13.15.0 with the patch otherwise I have about 40 phones (cisco 9971) I bought incredibly cheap that I won’t get the best functionality out of.

Thank you in advance,


It seems the answer was obvious and I panicked a bit early.

When installing via iso, the models of freepbx are loaded automatically. When installing from tarball, only the bare-minimum modules are loaded automatically.

Installing them is very easy however. To install “print extensions” for example, one does that in the module admin section of the freepbx UI.

What I did (to save time) was to install them from the command line, using “fwconsole”. On my iso-installed freepbx I executed “fwconsole ma list | grep GPL” and received a list of all the modules installed from the ISO that are GPL and AGPL licensed. I parsed that list and executed “fwconsole ma downloadinstall” for each and the deed was done.

Fought for a while with the error “conference bridge not installed” but using other support threads here I got that working consistently.

I just wanted to put the solution I used in case others land here with their search.