Upgraded to freepbx13 and can't access recordings page

i am running the freepbx installed from the distro cd. It is the SHMZ release 6.5 (Final)
Yesterday, i updated the freepbx from version 12 to 13 following the link from the gui menu.

it seems that it didn’t do it successfully. I cannot access the recording’s page anymore (but the CDR reports is working fine though).
Please see the attached screenshots. One fault i see is that the process management module cannot be upgraded because the “node package manager” is not installed. I tried several tutorials on the web on how to install the latest version of nodejs in centos without success.
And my question is if i can easily fix the above nodejs problem in order to install the process management module
and another question is if i download the latest distro with freepbx if i will lose data because my centos machine is doing other tasks simultaneously (streaming, hosting, running cron tasks etc). Thank you

Try installing pm2 from bash

fwconsole ma downloadinstall pm2 --force

Also, are you using FaxPro? If not, remove it

fwconsole ma delete faxpro

This is the problem. You need to upgrade the OS as well using the Distro upgrade scripts:


Thank you for your answers
PitzKey unfortunately they didn’t help

lgaetz, will the scripts upgrade both the os and the freepbx without losing other data? (that happens when you do a clean install)

and another question, does the System Admin module (25,00$) upgrade the system automatically? (now and for the coming years) . Thank you

Yes. Obviously it would be wise to ensure you have a backup prior to running the scripts in case it’s needed for disaster recovery.

In addition to other features, sysadmin pro will download and run the Distro upgrade scripts for you without needing to use the command line. You still need to initiate the update by clicking a button.

Igaetz, Thank you i purchased the sysadmin module and the access to the gui of the freepbx stopped. I cannot access the system through my browser. The cli is running though. I changed my ips in case i was banned but nothing happened. I tried these bash commands:

fwconsole ma upgrade all
fwconsole ma install core
amportal a ma download sysadmin
amportal a ma remove sysadmin
fwconsole reload
amportal a ma uninstall sysadmin

none of the above helped.i also rebooted the machine. Any other command to try please?

What are you trying to do here?

Do you get any errors when trying to access the GUI?

About the only thing I can think of that might change when installing sysadmin would be the Admin GUI port. The admin GUI port should be the first value returned from this:

grep Listen  /etc/httpd/conf.d/schmoozecom.conf

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.