Upgraded to 12 RC outbound call problem

Hi so i’ve decided to take a plunge and upgrade to 12RC, since it’s system that i’m still testing.
So i went through updating followed the wiki and all modules are updated now…

Just FYI on 2.11 everything worked as expected, INBOUND, OUTBOUND and between then and upgrade no changes were made to firewalls etc.

It seems like all my settings stayed and my test extension is registering just fine (softphone), my trunk is registered as well. I can make inbound call to my DID and get to my IVR.

The only thing that doesn’t work is outbound calling when i dial a number im getting this in the log

[2014-09-05 02:32:20] VERBOSE[4051][C-00000024] pbx.c: – Goto (restrictedroute-0,18006522253,2)
[2014-09-05 02:32:20] WARNING[4051][C-00000024] pbx.c: Channel ‘SIP/315-0000000a’ sent to invalid extension but no invalid handler: context,exten,priority=restrictedroute-0,18006522253,2

the trunk should be correct if im able to reach my PBX using the DID ? but then again my trunk config is the same as before the upgrade.

Any information is highly appreciated.


seem that i’ve hit this bug


disabling Extension Routes (COMMERCIAL) module seemed to resolve the issue.

As far as 12RC i like the new GUI, kinda miss Trunks and Phones online info from the System Status page

Other than that great job guys!

Please comment on said bug. We asked for more people to comment otherwise it will never get fixed.

I can also confirm that on 3 of my PBX systems after the update to 12 I had to disable the Extension Routes Module.

Please comment on the bug or we are going to close this issue and move on.

i added my comment to the issues. thanks tm1000

1 Like

Resolved in Extension Routes 12.0.6

thanks tm1000. updated the module and enabled and not seeing the error anymore. good stuff!

1 Like

Fantastic to hear! These bugs are always quirky and finicky

Was a little to quick with it. It’s not giving me any problems but i also don’t see Extension Routing options under any user’s extension since

Is the module licensed. You’ll only see that if it’s actually licensed.

It’s also not called “extension routing” in the extensions page and it’s collapsed by default. So you really have to look for it

1 Like

hi tm1000. Nope it says i have a button to “obtain free license” that just goes to the Shmooze.com page where i log in with account that i registered my PBX deployment with (i have SysAdmin and Endpoint Manager commercial modules registered and licenses there). I tried going to the store etc but can’t find Extension Routing anywhere.

EDIT: After luring around the store i found the free Extension Routing module added it to cart applied to my deployment and checked out. Do i have to reboot the server in order for it to pick up the newly licensed module ?
Or do i have to give it some time to apply?

If you go under sys admin module and press licence, there should be a button to check/update your license.

1 Like

thanks aaronhurst. i just checked and it the module updated itself to Licensed so no need to go to Sys Admin module but i’ll remember that in the future. thanks again!

Does it still work for you after registered. There is another user saying it doesnt work?

1 Like

tm1000, yes it works fine. created another outbound route with different dial plan and assigned to test user. user can dial out local # without entering area code just fine. another user on different outbound route can do the same for different area code.

1 Like