Upgraded PBXact 14 to 15 and now issues


(Matt) #1

Hey all,

Upgraded from 14 to 15 using the upgrade tool in the GUI. After the update, it’s saying system isn’t activated and I’m unable to get into the system admin module.

Error I’m getting is Error(s) installing sysadmin:

Core module version 15.0.0 or higher is required, you have 14.0.28.19

Tried to update core using fwconsole ma update core and result was “core does not exist online, unable to ugprade” Any ideas on what to try? I can revert to a backup if need be.

Thanks!


(Matthew Fredrickson) #2

Sorry about the trouble :frowning:

Even though FreePBX 15 is released, PBXAct 15 is not released at this time. Usually there’s a 6 month lag after a FreePBX release before a new version of PBXAct is released as a product. I’m guessing that’s why you’re seeing problems.

Matt


(Matt) #3

Hm…ok thanks. It’s telling me now I can’t restore from a backup I made from before…anything I can do about that?


(Doug Kuhns) #4

Fantastic. Here I was all excited to try out PBXact 15 and now I ran into the same problem. Would be nice if it told you it didnt’ work when you run the upgrade wizard…


(Lorne Gaetz) #5

Hi @ozarktech

If you can easily revert to a backup then prob best to do so. If you can’t or wish to proceed with 15, you should be able to by removing the PBXact branding with:

fwconsole ma delete oembranding

The licensing you have now will remain intact, but the PBX appearance will look like FreePBX. You can reinstall the skinning module at some later date once it’s been announced as ready.


(Matt) #6

How would we bring the licensing back after it is released?

Also, is there any way to use the System Admin module in FreePBX or does that not exist?

Thanks.


(Lorne Gaetz) #7
fwconsole ma downloadinstall oembranding

System admin module exists in FreePBX same as PBXact.


(Doug Kuhns) #8

Ok thanks! And how will we know when PBXact 15 is released?


(Matt) #9

Thank you! After the upgrade, mine is showing as disabled and says pending upgrade. When I try to run the upgrade, it says Error(s) installing sysadmin:
* Core module version 15.0.0 or higher is required, you have 14.0.28.19

But says no core upgrade is available.


(Lorne Gaetz) #10

Thinking further, there is probably no way forward for you in the short term. There are repo changes required for PBXact that are not in place. Back to my plan A, restore from a backup.


(Matt) #11

Ok, thanks. Trying to restore from backup from before the upgrade results in an error because it requires a backup from version 15, not 14…

It’s running on a physical Sangoma box too, not a VM so no snapshot or anything.