Upgraded Modules - Now PJSip Always Shows Anonymous


(Thetoad30) #1

I had one of my FreePBX machines crash and have disk errors. I repaired them, but to be safe, I migrated to a new FreePBX install.

That install will accept no incoming calls. They are always anonymous, even if the IP is in the subnet range of the pjsip list identifies command.

I resurrected my old FreePBX box, and everything worked as expected. As soon as I upgraded the modules, incoming calls stopped working.

I noticed that the global variable SIPDOMAIN changed from my local machine’s IP to my external IP after the modules upgraded.

Is this a bug?

EDIT:

So I restored to a snapshot I had of my old box, and the calls are working again. Something is not working with whatever updates I installed.

Working Version:
Working%20FreePBX%20Version

Not working version:
Not%20Working%20FreePBX%20Version


#2

your domain would best be your fully qualified name, and your endpoints would be best registering/qualifying against that name, and not the ip, if you do that your passed ‘spam calls’ will approach zero


#3

My system shows
pbx_variables.c: Setting global variable 'SIPDOMAIN' to '(my external IP)'
but receives incoming calls just fine, so I suspect that this is unrelated to your issue.

At the Asterisk command prompt, type
pjsip set logger on
and make a failing test call.

Paste the relevant section of the Asterisk log, starting from the first line related to the call, through when the call was identified as anonymous, redacted as desired, at https://pastebin.freepbx.org and post the link here.

Also post:
Is the problematic trunk using registration, routing to host, or SIP URI?
If you have multiple trunking providers, do they all fail in this way?
Confirm that internal and outgoing calls work properly (the call leg from the extension to the PBX is an ‘incoming call’ to pjsip).


(Thetoad30) #4

Working Call:
https://pastebin.freepbx.org/view/4a7893c4

Non-Working Call:
https://pastebin.freepbx.org/view/e7ca374a

After upgrading, all of my DIDs do not work. They all do the same thing with incoming calls.

All outgoing calls to external numbers work as expected. Internal (extension to extension) also work fine.

Trunks are registered, outgoing.

Thank you for your help.


(Dave Burgess) #5

You need to add the addresses for the calls to your “Permit” line in the Advanced settings in your PJ-SIP Trunk definition. For example, 199.255.120.176 is listed as a call source that generates an error.


(Thetoad30) #6

I understand that - but FreePBX was detecting these before, and now it’s not. It should be getting these from the provider like it did before, right? It should be based off of the subnet, but it’s not detecting the subnet range properly anymore.