Upgraded from 813 to 814 and DAHDI & Wanpipe are hosed

Vanilla FreePBX Distro been upgraded as new upgrades were released. No extra software. Hardware is Sangoma A200 card. Upgraded to the 814 release and DAHDI was reporting missing. Setup Sangoma complained about DAHDI and Wanpipe not available and Wanpipe isn’t running. Running a 32 bit Dell platform.

Any suggestions?

I would suggest using support if that is all the information you can provide.

The first step is to make sure that DAHDI and Wanpipe are installed. Then manually check their configuration files.

Installed both DAHDI and Wanpipe after updating the development tools. (missing libraries caused mismatches with the Wanpipe utlities) Why would the update from 813 to 814 cause this? The DAHDI and Wanpipe repros all reported as in place and properly updated. It just looks like they never got compiled into the active.

Sigh…

Terminal capture after update:
[[email protected] ~]# setup-sangoma…
Warning: Dahdi modules not found: Wanpipe not build for DAHDI
Error: Dahdi and/or Zaptel modules not found! Please install DAHDI and compile Wanpipe for DAHDI!
Then

[[email protected] upgrade]# service dahdi start
Loading DAHDI hardware modules:
FATAL: Module dahdi not found.
wct4xxp: FATAL: Module wct4xxp not found.
[FAILED]
wcte12xp: FATAL: Module wcte12xp not found.
etc

Downloaded complete and installed just fine.
Then downloaded Wanpipe and during setup got this:

WARNING: You are missing some prerequisites

ncurses library.
Required for wancfg and cfgft1 configuration utilities.
Install ncurses development package (e.g yum install ncurses-devel).

Flex package .
Required for Wancfg configuration utility.
Install flex package (e.g yum install flex).

Libtermcap development tools .
Required for Wanpipe Utilities.
Install libtermcap-devel package (e.g yum install libtermcap-devel).

Bison.
Required for Wanpipe Utilities.
Install bison package (e.g yum install bison).

Libtool.
Required for libsangoma.
Install libtool package (e.g yum install libtool).

And more in the middle of the compiling messages.
Found this gem on the Sangoma site:
yum -y install kernel-devel-$(uname -r) libtool* make gcc patch perl bison gcc-c++ ncurses-devel flex libtermcap-devel autoconf* automake* autoconf

It updated the needed development libraries. Then reran ./Setup dahdi and all was well. (After running the normal setups for the A200, etc.)

I just hope this doesn’t break next update released for FreePBX Distro!

Fred

It didn’t but now you are “off the repo”.

The Repo has DAHDI and Wanpip rpm’s I would have installed via the rpm.

Did you run the distro upgrade script? Did you skip one?

Yeah we just did two upgrades ourselves tonight and I had Robert check the wanpipe on them and they were fine.

It’s been a pure install from day one. I upgrade following the list with no shortcuts. Didn’t know the rpm and didn’t find anything in the forums that even hinted that there was an alternative. I guess that I’ll make sure I have a very good backup before I try the next upgrade script!

BTW even though I’m in Florida and my kids are all Gators I graduated from Kent State and miss the old home Ohio…

Later,

Just tested this upgrade on 2 servers and it worked fine.

Without knowing what version you had prior and what you all did I could not tell you but it sure seems like you enabled a different yum repo like Centos or EPEL or something for that to break

Did you reboot after each upgrade script?
the last line of the upgrade scripts tells you to reboot the system to apply updates to Dahdi. Maybe you missed a reboot and the versions got mixed up?

The problem is the centos repo upgrades the kernel to 2.6.18-308.11.1.el5, while the dahdi drivers are built for 2.6.18-308.4.1.el5. I upgraded a system a couple of days and a new kernel was not included. So it must be a recent add to the centos repo.

You can edit the /boot/grub/menu.lst and change the default to point to the kernel-2.6.18-308.4.1.el5. Then reboot the system and everything should come up properly.

I ran into what seems to be the same issue as fredr.

  • Fresh install of FreePBX-1.813.210.58-i386-Full-1339178731.iso. The kernel is 2.6.18-308.4.1.el5 and wanpipe package is wanpipe-3.5.26-kernel.2.6.18.308.4.1.el5.dahdi.2.6.1. Wanpipe drivers load fine.

  • Ran upgrade script upgrade-1.814.210.58-1.sh. Kernel automatically updated to 2.6.18-308.11.1.el5. However, there is no matching wanpipe package in the repo.

yum update

yum info wanpipe


Release : kernel.2.6.18.308.4.1.el5.dahdi.2.6.1

Regards,
Tim Miller Dyck

I will have to dig into the repos on why there is a newer kernel

I dont see 2.6.18-308.11.1.el5 kernel in our repo. You sure you did not activate a different repo like from Centos direct?