Upgraded from 13 to 14.. multiple modules not working and can't apply config

Hi all,

I recently upgraded to 14 from 13. Some modules are throwing error and when trying to apply config as well. Hope someone can help with this. Thanks

When applying config:

Reload failed because retrieve_conf encountered an error: 1

exit: 1
Unable to continue. Illegal string offset ‘target’ in /var/www/html/admin/modules/customappsreg/functions.inc.php on line 59 #0 /var/www/html/admin/modules/customappsreg/functions.inc.php(59): Whoops\Run->handleError(2, ‘Illegal string …’, ‘/var/www/html/a…’, 59, Array) #1 /var/www/html/admin/libraries/usage_registry.functions.php(300): customappsreg_getdestinfo(‘ext-queues,302,…’) #2 /var/www/html/admin/libraries/usage_registry.functions.php(351): framework_identify_destinations(Array, Array) #3 /var/lib/asterisk/bin/retrieve_conf(818): framework_list_problem_destinations(Array, false) #4 {main}

Some module shows the below error.
Whoops \ Exception \ ErrorException (E_WARNING)

Illegal string offset ‘destret’















  1. <?php
  2. if (!defined(‘FREEPBX_IS_AUTH’)) { die(‘No direct script access allowed’); }
  3. // License for all code of this FreePBX module can be found in the license file inside the module directory
  4. // Copyright 2013 Schmooze Com Inc.
  5. //
  6. function customappsreg_destinations() {
  7. // return an associative array with destination and description
  8. $allDests = \FreePBX::Customappsreg()->getAllCustomDests();
  9. if (!$allDests) {
  10. return null;
  11. }
  • $extens = array();
  1. foreach ($allDests as $row) {
  2. // If this has a return flag, we need to wrap it.
  3. if ($row[‘destret’]) {
  4. $dest = “customdests,dest-”.$row[‘destid’].",1";
  5. $extens[] = array(‘destination’ => $dest, ‘description’ => $row[‘description’], ‘category’ => _(“Custom Destinations”), ‘id’ => ‘customdests’);
  6. } else {
  7. $extens[] = array(‘destination’ => $row[‘target’], ‘description’ => $row[‘description’], ‘category’ => _(“Custom Destinations”), ‘id’ => ‘customdests’);
  8. }
  9. }
  10. return $extens;
  11. }
  • /** the ‘exten’ is the same as the destination for this module
  1. */
  2. function customappsreg_customdests_getdest($exten) {
  3. return array($exten);
  4. }
  • /** If this is ours, we return it, otherwise we return false
    • We use just use customappsreg and not the display because it
    • is a per-module routine
  1. */
  2. function customappsreg_getdestinfo($dest) {
  3. global $active_modules;
  • $allDests = \FreePBX::Customappsreg()->getAllCustomDests();
  1. // Look for $dest in allDests. If we know about it, then return


  1. “Illegal string offset ‘destret’”

What module is this? I don’t think I’ve ever heard of it.

Hi Lorne,

To tell you the truth, I am not 100% sure what this module does. I inherited this box from another tech unfortunately. :frowning:

Tried googling it and comes as Custom Applications - Registry to add custom extensions and destinations that may be created and used so that the Extensions and Destinations Registry can include these.

Hi again,

Found it under module admin in freepbx.

Hi Lorne,

Just want to give you an update. I think I managed to sort this one out. I disabled the following modules and all seems to be working fine now.

-Custom Applications
-Appointment Reminder

Just want to check if disabling custom applications and AMD won’t cause issue. The other 2 are commercial modules so should be fine to disable them.

Thanks for your help.

Hi Lorne,

I just realized I haven’t been tagging you in the replies… sorry! :slight_smile:

Bad info on my part, customappsreg is a legit published module, just one I rarely use. If the same error happens again when you reinstall, I would open a bug ticket.

Otherwise, if you have things working now without those modules, you’re probably fine.

Hi Lorne,

All seems to be working fine now. I will try to reinstall the modules and open a ticket as suggested if it still has the same issue. Thansk for your help.

I will need to open anotehr ticket now as transferrd calles are dropping out… not sure what could be the cause of this. :frowning: Hopefully I can get this sorted and move on with life!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.