Upgrade to Framework Version 12.0.41 brakes Frontend

[developers note]: OBE has been in FreePBX since 2.11 in 12.0.41 it was abstracted so that other distributions can make and design their own OBEs. In this situation the two systems listed below were in development mode. Development mode is enabled during install when running with --dev-links, --update-links or --install-links. Any of these options will enable developer mode which symlinks all files, if a new file is added then that file wont be symlinked unless --update-links is run. It’s highly advisable to not run in development mode

Hello everybody

After Upgrading the Framework from 12.0.40 to 12.0.41 i just get a blank page at the frontend. Apache throws a fatal PHP error.

PHP Fatal error: Uncaught exception ‘Exception’ with message 'Unable to locate the FreePBX BMO Class ‘OOBE’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) amportal a ma install oobe 2) amportal a ma enable oobe’ in /usr/local/src/freepbx/amp_conf/htdocs/admin/libraries/BMO/Self_Helper.class.php:205\nStack trace:\n#0 /usr/local/src/freepbx/amp_conf/htdocs/admin/libraries/BMO/Self_Helper.class.php(100): Self_Helper->loadObject(‘OOBE’)\n#1 /usr/local/src/freepbx/amp_conf/htdocs/admin/libraries/BMO/Self_Helper.class.php(36): Self_Helper->autoLoad(‘OOBE’)\n#2 /usr/local/src/freepbx/amp_conf/htdocs/admin/config.php(348): Self_Helper->__get(‘OOBE’)\n#3 {main}\n thrown in /usr/local/src/freepbx/amp_conf/htdocs/admin/libraries/BMO/Self_Helper.class.php on line 205

As far as i know there is no module named oobe. If i try it nevertheless like it tells me i just get

amportal a ma download oobe

Please wait…

The following error(s) occured:

  • Retrieved Module XML Was Empty

Any idears how to solve that Problem?
PHP 5.4.36
Asterisk 13.2
Apache 2.2.22
MySQL 5.5.41

Best Regards


OOBE is a new BMO module, that provides a better Out of Box Experience.

The file /var/www/html/admin/libraries/BMO/OOBE.class.php provides it - is that file missing?

Edit: Oh - I just noticed the path - /usr/local/src/freepbx/amp_conf/htdocs/admin/libraries/BMO/Self_Helper.class.php – that means you’re in development mode. You shouldn’t be using online updates for framework. Do a git update and then ./install_amp --update-links.

Hello my friend

I have the same problem, but I do not understand the instructions to fix it well. Might be more specific. I have installed on my server.

Core 12.0.24
Framework 12.0.43
PHP 5.4.9 ubuntu
Asterisk 1.8.13 ubuntu
Apache 2.2.22 Ubuntu
MySQL 5.5.41

What instructions did you follow to install it?


The Bug seemed to be quite simple. I’m not using the dev Branch. The cause for the files beeing saved at /usr/local/src is, that the Install script is just linking the files to the actual webserver root path. And that leaded in fact to the error i described above too. The upgrade routine placed the OOBE.class.php at /var/www/admin/libraried. All other libraries instead are placed at /usr/local/src/freepbx/amp_conf/htdocs/admin/libraries. So i only had to move the OOBE file to the right place and to run the script which updates the linked files and it worked again.

I worked correctly. but in my case, I had to move the OOBE.class.php file. the path: / usr / src / freepbx / amp_conf / htdocs / admin / libraries / BMO /
Update and then a ./install_amp --update-links. Restart Asterisk and apache.


–update-links means you are in developer mode. If FreePBX is symlinking you are both in developer mode. No matter what you tell me. You are in developer mode. You need to install FREEPBX correctly. Both of you have it installed wrong for an end user.

For myself i’m pretty sure that i’m not in freepbx dev mode. Maybe my installation is :smile:. I installed it exactly as descibed in http://wiki.freepbx.org/display/HTGS/Installing+FreePBX+12+on+Ubuntu+Server+14.04+LTS#InstallingFreePBX12onUbuntuServer14.04LTS-DownloadandextractFreePBX. If thats a dev mode installation, you are right with your suggestion.
Anyway thanks for your help. So you might could tell us how to migrate to a enduser installation?

Best Regards Jakob

You have to reinstall from scratch. Your installation is in development mode.