Upgrade scripts are getting SLOOWWW

Each script tries to install arimanager (and fails because Asterisk 1.11) and then ucpnode (which succeeds each time) at least three times for each script - if you install from the .ISO you are at - which means 11 scripts and ucpnode being installed at least 33 times - it is taking forever!

Any way I can help make the scripts a little less repetitive and faster?

Upgrade option 2 from this page:



and go make some coffee. It will not make the scripts faster, but you can upgrade to current unattended.

I used to use Sysadmin Pro to get all the updates, but for quite a while it was stalling/failing - has this been fixed?

Is there anything to fix? When you are done running the script, are all modules not up to date and firmware version incremented?

No, it was stalling as in not finishing the scripts - just sort of stopping - I haven’t tried in probably a year, so it might not be a thing anymore - when it started doing it, I switched to running the scripts manually - that UCP-Node is just starting to make this way of doing it painful. I will try on the next machine to use SysAdmin Pro.

I don’t understand. Ucpnode should upgrade once. If it’s upgrading on every script one after another then it’s not installing and something is wrong on your box.

Actually, the upgrade is failing on a fresh load - and it is reproducible - UCPNode keeps failing over and over again - I am using the 64-Bit ISO and then trying to use the scripts to upgrade - System Admin shows so I start with the .7 upgrade script and it fails over and over all the way up to

And even after I still don’t have a working install of UCP Node Server.

Give us an error to go on

This is the same error I get whether I use an Upgrade Script or like below - just trying to install it:

fwconsole ma download ucpnode --edge
fwconsole ma install ucpnode

Stich is Sad:

Did you try to run the command it couldn’t run?

Pretty Colors:

Do I need to update Node,js to Edge also?

No. You can’t do that. There is no Node,js module.

Please post the output of:



-rw-rw-r-- 1 asterisk asterisk 0 Jan 16 15:10 /var/log/asterisk/ucp_err.log


I tried to replicate this particular issue and I’m unable unfortunately. I removed ucpnode completely. Twice and it reinstalled again each time.

I suggest just removing ucpnode.

Removing it and then re-installing it? Did that - Success - Weird - because I had tried that before…

You know one thing - I did not restart after the first upgrade script - that replaced the Kernel - you don’t have a dependency there do you?

No but we also just forced it to install even if it fails to start so it still might not be running but at least it gets you farther in the process.