Upgrade 15 > 16 - Stuck Upgrading Transaction

Hi all,

I’m in the process of upgrading a production server. The upgrade check passed so I thought I was in the clear. My machine is running on Vultr and I’ve had 2 other successful Vultr upgrades to 16, so not sure what is wrong with this one. I took a snapshot before starting the upgrade, and when I attempted the upgrade using the web interface, things failed so I restored and re-ran using the console.

On my second try, I followed the guidance in this thread and my upgrade is getting stuck in the same spot:

Sun Nov 21 09:51:33 PST 2021 sysadmin16 installed successfully....

Sun Nov 21 09:51:33 PST 2021 Installing PBX RPM

Sun Nov 21 09:51:33 PST 2021 Node Service will restart , it will automatically start to fetch the update progress..

Sun Nov 21 09:51:33 PST 2021 Do not refresh browser !!..

Loaded plugins: fastestmirror, versionlock

Repository sng-sng7php74 is listed more than once in the configuration

Cleaning repos: sng-base sng-epel sng-extras sng-pkgs sng-sng7php74 sng-updates

Cleaning up list of fastest mirrors

Other repos take up 227 M of disk space (use --verbose for details)

Loaded plugins: fastestmirror, versionlock

Repository sng-sng7php74 is listed more than once in the configuration

Determining fastest mirrors

Resolving Dependencies

--> Running transaction check

---> Package freepbx16.x86_64 0:16.1-1.sng7 will be installed

--> Finished Dependency Resolution



Dependencies Resolved



================================================================================

 Package          Arch          Version              Repository            Size

================================================================================

Installing:

 freepbx16        x86_64        16.1-1.sng7          sng-sng7php74        767 M



Transaction Summary

================================================================================

Install  1 Package



Total download size: 767 M

Installed size: 1.7 G

Downloading packages:

Running transaction check

Running transaction test

Transaction test succeeded

Running transaction

Any guidance is greatly appreciated!

I’m doing an upgrade of a system on Vultr right now and it had no issues moving past that step.

When things like this happen, you need to open another connection to the instance and check top or htop and see what is happening.

I always perform the upgrade from a ssh connection so if there is a problem, I can log in to the Vultr console and check things.

Thanks- I opened another session and checked top. There was a bit of activity with Node, and Asterisk was running. Is there anything I need to be looking out for?

The 2 other instances I successfully upgraded were also on Vultr. I definitely don’t think the issue with this box has anything to do with that.

In case it’s of any use, I’ve attached a couple GIFs of what I’m seeing with top and htop.

Here is the upgrade log: 15>16 Upgradde Issue - FreePBX Pastebin

Just wanted to report back as I dig deeper into the issue. This particular box has mounted block storage at /var/spool/asterisk/monitor on Vultr and I suspect the install is getting stuck on this. Unmounting and running yum install freepbx16.x86_64 0:16.1-1.sng7 allows the package to install successfully (but the version upgrade is still corrupted).

When I tried removing and reinstalling the freepbx16.x86_64 0:16.1-1.sng7 package I would get a warning: directory /var/spool/asterisk/monitor: remove failed: Device or resource busy error which is how I worked it out.

I’m in the process of restoring my snapshot and will first unmount the block storage before beginning the upgrade, then I will remount it after it’s finished. I will report back if this works!

My upgrade of a physical install is getting stuck at the same spot, “Running transaction” it appears. Confirming you weren’t able to recover without essentially starting over?