Updating Asterisk to 15 from 13 broke my install

I upgraded my FreePBX 14 to 15, and that all went mostly without a hitch, once it was happy and not showing any issues I though I should bring my asterisk up to date so I tried to use the /usr/local/sbin/asterisk-version-switch which gave me the choice of versions, probably ill-advisedly I chose 16, which broke the system - I then tried to drop back to 15 which did not improve matters and then back to Asterisk 13 which also shows the same issues…

php: Unparseable output from getservices - [“Exception: Asterisk is not connected in file /var/www/html/admin/libraries/php-asmanager.php on line 248”,“Stack trace:”," 
1. Exception->() /var/www/html/admin/libraries/php-asmanager.php:248"," 
2. AGI_AsteriskManager->send_request() /var/www/html/admin/modules/firewall/Smart.class.php:447"," 
3. FreePBX\modules\Firewall\Smart->getPjsipContacts() /var/www/html/admin/modules/firewall/Smart.class.php:437"," 
4. FreePBX\modules\Firewall\Smart->getRegistrations() /var/www/html/admin/modules/firewall/Smart.class.php:69"," 
5. FreePBX\modules\Firewall\Smart->getAllPorts() /var/www/html/admin/modules/firewall/Firewall.class.php:1026"," 
6. FreePBX\modules\Firewall->getSmartPorts() /var/www/html/admin/modules/firewall/bin/getservices:22"] - returned 1

" fwconsole ma upgradeall
Up to date.
Updating Hooks…Done"
Yum shows no errors and everything is up to date…
asterisk is not started with the systemctl (all off) but does start on reboot

I have rebooted several times and I reinstalled sangoma-pbx just in case that was an easy fix.

Asterisk IS running but does not seem to be connected to FreePBX as i can attach with -rvv but there is no config.

Has anyone any pointers or advice - I fear that “asterisk-version-switch” is going to cost me a lot of time over this weekend.

Error in log currently shows following after reinstalling firewall and XMPP

php: Unparseable output from getservices - ["Exception: Asterisk is not connected in file \/var\/www\/html\/admin\/libraries\/php-asmanager.php on line 248","Stack trace:","  
1. Exception->() \/var\/www\/html\/admin\/libraries\/php-asmanager.php:248","  
2. AGI_AsteriskManager->send_request() \/var\/www\/html\/admin\/modules\/firewall\/Smart.class.php:447","  
3. FreePBX\\modules\\Firewall\\Smart->getPjsipContacts() \/var\/www\/html\/admin\/modules\/firewall\/Smart.class.php:437","  
4. FreePBX\\modules\\Firewall\\Smart->getRegistrations() \/var\/www\/html\/admin\/modules\/firewall\/Smart.class.php:69","  
5. FreePBX\\modules\\Firewall\\Smart->getAllPorts() \/var\/www\/html\/admin\/modules\/firewall\/Firewall.class.php:1026","  
6. FreePBX\\modules\\Firewall->getSmartPorts() \/var\/www\/html\/admin\/modules\/firewall\/bin\/getservices:22"] - returned 1

asterisk isn’t running or is running as root

Asterisk is running but not as root.

root     11545  0.0  0.0 113176   804 pts/4    S    19:16   0:00 /bin/sh /sbin/safe_asterisk -U asterisk -G asterisk
asterisk 11547  0.0  0.4 1713524 27192 pts/4   Sl   19:16   0:00 /usr/sbin/asterisk -f -U asterisk -G asterisk -vvvg -c

I can kill them both off and then restart with fwconsole which gives.

root      3115  0.0  0.0 113176   808 pts/3    S    19:54   0:00 /bin/sh /sbin/safe_asterisk -U asterisk -G asterisk
asterisk  3117  2.0  0.4 1485572 25220 pts/3   Sl   19:54   0:00 /usr/sbin/asterisk -f -U asterisk -G asterisk -vvvg -c

fwconsole gives…

[--------------->------------] 12 secs
In Start.class.php line 189:

  Unable to connect to Asterisk. Did it start?

If Asterisk is running and running as user asterisk, then check that the manager user/password in Advanced Settings matches the values in /etc/asterisk/manager.conf. Also make sure there is not a second conflicting admin user.

1 Like

good call… there was NO manager.conf but there WAS manager.conf.rpmnew and manager.conf.rpmsave… I copied conf.rmpsave to .conf and the GUI has “found” asterisk - but the whole thing is broken – BUT – I have:-


which I presume asterisk-version-switch did to me… or my fiddling… i will rename them all and see what that brings…

Well, that brought it back to life. I will take a backup to be sure and then think about updating to Asterisk 15 again… should “/sbin/asterisk-version-switch” work with this system?

FreePBX and Asterisk 13?

Thanks for the help bringing it back to life, I ran asterisk-version-switch, and this time it worked without hitch. I am not really wiser about what actually happened but will not fiddle more.

This isn’t a production PBX is it? Because FreePBX v15 is BETA and not recommended for production environments.

No, not production, sits in a cupboard at home… does good work for me (and the family) but is just the three of us here… and the other two don’t use the desk phones much…

That’s fine. A few have decided to update their production systems to this version and it’s just not a wise idea right now. Home/light use should be fine.

Actually, i was only vaguely aware it was still beta… and i have been finding a couple of issues i should report back on. Will search them up and report if not already listed.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.