Updating Asterisk 11.X and best practices [SOLVED]

Hi,

I manage a few FreePBX (AsteriskNOW) 2.11 installs, and they are all running Asterisk 11.14. Noticing the new release announcements from asterisk-users, recently 11.22 was released and I figure I should look into keeping these boxes up to date.

Using yum, I went looking for available upgrades with;
yum list asterisk11*
yum upgrade asterisk11*
yum check-update astersik11*
…and so forth, but each time I may get a list of Installed Packages, No Match Found or No Package Marked for Update results.

Is there something I’m doing wrong to update from Asterisk 11.14 to 11.XX?

Is using yum the best way, and with least risk, to update Asterisk? Or, will this have impact on FreePBX?

Is there a better way of performing updates to Asterisk, and getting any relevant updates that FreePBX requires at the same time? That is, is there a “best practice” when it comes to updating?

Thanks for your time.

Maybe try “yum search asterisk” to make sure you are listing it correctly.

Or just try “yum update” to see what comes up.

Hi GeekBoy,

So, a yum search asterisk yields a lot of packages for all Asterisk versions, here is the output of yum search asterisk11;

========================================================= N/S Matched: asterisk11 ========================================================== asterisk11-debuginfo.i686 : Debug information for package asterisk11 asterisk11-flite-debuginfo.i686 : Debug information for package asterisk11-flite asterisk11.i686 : Asterisk, The Open Source PBX asterisk11-addons.i686 : Asterisk-addons package. asterisk11-addons-bluetooth.i686 : bluetooth modules for Asterisk asterisk11-addons-core.i686 : Asterisk-addons core package. asterisk11-addons-mysql.i686 : mysql modules for Asterisk asterisk11-addons-ooh323.i686 : chan_ooh323 module for Asterisk asterisk11-alsa.i686 : Alsa channel driver for Asterisk asterisk11-configs.i686 : Basic configuration files for Asterisk asterisk11-core.i686 : Asterisk core package without any "extras". asterisk11-curl.i686 : cURL application module for Asterisk asterisk11-dahdi.i686 : DAHDI channel driver for Asterisk asterisk11-devel.i686 : Static libraries and header files for Asterisk development asterisk11-doc.i686 : Documentation files for Asterisk asterisk11-flite.i686 : Flite text-to-speech module for Asterisk asterisk11-odbc.i686 : Open Database Connectivity (ODBC) drivers for Asterisk asterisk11-ogg.i686 : Ogg-Vorbis codec module for Asterisk asterisk11-pgsql.i686 : Postgresql modules for Asterisk asterisk11-res_digium_phone.i686 : Provides a number of enhanced provisioning and application capabilities for Digium SIP phones asterisk11-resample.i686 : resampling codec module for Asterisk asterisk11-snmp.i686 : snmp resource module for Asterisk asterisk11-speex.i686 : Speex codec module for Asterisk asterisk11-sqlite3.i686 : sqlite3 drivers for Asterisk asterisk11-tds.i686 : tds modules for Asterisk asterisk11-voicemail.i686 : Voicemail with file storage module for Asterisk asterisk11-voicemail-imapstorage.i686 : Voicemail with IMAP storage module for Asterisk asterisk11-voicemail-odbcstorage.i686 : Voicemail with ODBC storage module for Asterisk

Can’t tell what versions these are though.

Running just yum update goes through and lists packages

---> Package tzdata.noarch 0:2015g-2.el6 will be updated ---> Package tzdata.noarch 0:2016c-1.el6 will be an update ---> Package vsftpd.i686 0:2.2.2-14.el6 will be updated ---> Package vsftpd.i686 0:2.2.2-14.el6_7.1 will be an update

But ends with

---> Package libresample.i686 0:0.1.3-4_centos6 will be updated --> Processing Dependency: libresample.so.1.0 for package: asterisk11-core-11.14.2-1.shmz65.1.41.i686 --> Finished Dependency Resolution Error: Package: asterisk11-core-11.14.2-1.shmz65.1.41.i686 (@pbx) Requires: libresample.so.1.0 Removing: libresample-0.1.3-4_centos6.i686 (@anaconda-PBX-201403180433.i386/6.5) libresample.so.1.0 Updated By: libresample-0.1.3-12.el6.i686 (epel) Not found You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

And, never goes on to the next step where yum shows a summary of what will be updated, to what version and confirm to go ahead. Perhaps there is an issue with the asterisk11-core package, or yum, or the repo’s?

I am a network engineer by trade so apologies that these questions are pretty basic - I don’t have a great understanding of yum & linux but well and truely enough to get myself into trouble :wink: :smiley:

Edit: Thought I’d mention that I’ve updated an Asterisk 13 FreePBX distro via yum simply with ‘yum update asterisk13*’, so figured it should be the same to update asterisk11.

The Problem is you have two conflicting repos. Disable the EPEL one and see how that works out.

Should be /etc/yum.repos.d/epel.repo

Fantastic … I set EPEL to enabled=0 in the file you linked. It’s not showing up now as being checked, and running a test of ‘yum update’ is working fine now. I can see now the error that libresample was updated by EPEL, and I guess things didn’t like that …

However, running ‘yum update asterisk11*’ still gives me No Packages Marked for Update. Same with yum check-update, and no asterisk packages are listed in ‘yum update’. Is there a yum command that will display what version is available on the repo? Just wondering if I am missing a repo or have an old URL? Would the asterisk updates come from a repo in FreePBX.repo?

Thanks for your time.

Try “yum update asterisk”

The think is with so that repo conflict you had, no telling what may have been installed from it, which could create other problems.

The other thing is FreePBX may not be interesting in updating Asterisk 11 in their repo, or just have not gotten around to it.

One of them would have to answer that.

The ‘yum update asterisk’ doesn’t give any results - still No Packages Marked for Update.

I have a feeling you’re right about the FreePBX team not maintaining their repo for new Asterisk 11 updates. It makes sense that FreePBX 2.11 is EOL and EOS - but thus said, they are still updating modules in the UI such as Framework, so part of me wonders just how EOS FreePBX 2.11 is …

Would be nice for one of the devs to weigh in on this.

Thanks for your help and time, GeekBoy.

From what I am reading 2.11 is currently only getting security fixes until 14 comes out.

This is incorrect. We do maintain asterisk 11 along with asterisk 13.

However we do not maintain asterisk now. Digium does. Therefore it’d be up to them to update their own repository.

The freepbx distro has the latest asterisk 11 and 13.

Freepbx 2.11 is EOL but this has no bearing on asterisk versions.

Furthermore modules get updated in different branches. They don’t track framework/freepbx. So anything that is stable with the highest version being 2.11 will keep getting updates regardless of EOL versions. This is because the system is modular.

Thanks for dropping in, Andrew. I’m glad you cleared this up, and once I read your post kind of facepalmed - “but of course!”.

I’ll chase this up in some sort of Digium forum, or probably asterisk-users list.

It doesn’t look like AsteriskNow comes with any additional Digium-specific repo’s though:

[[email protected] yum.repos.d]# ls -la total 68 drwxr-xr-x 2 root root 4096 Apr 1 11:33 . drwxr-xr-x 104 root root 8192 Mar 11 09:50 .. -rw-r--r-- 1 root root 1958 Dec 9 2014 CentOS-Base.repo -rw-r--r-- 1 root root 638 Dec 1 2013 CentOS-Debuginfo.repo -rw-r--r-- 1 root root 630 Dec 1 2013 CentOS-Media.repo -rw-r--r-- 1 root root 4528 Dec 1 2013 CentOS-Vault.repo -rw-r--r-- 1 root root 957 Apr 1 11:27 epel.repo -rw-r--r-- 1 root root 1056 Nov 5 2012 epel-testing.repo -r--r--r-- 1 root root 1597 Sep 30 2014 FreePBX.repo -rw-r--r-- 1 root root 739 Mar 21 2013 mirrors-rpmforge -rw-r--r-- 1 root root 717 Mar 21 2013 mirrors-rpmforge-extras -rw-r--r-- 1 root root 728 Mar 21 2013 mirrors-rpmforge-testing -rw-r--r-- 1 root root 1128 Dec 1 2014 rpmforge.repo -rw-r--r-- 1 root root 219 Oct 5 2012 vz.repo

Thanks for everyone’s time and help.