Updates don't complete download


(Jerry Warner) #1

The past few weeks I’ve noticed that updates often don’t complete their download. For example this is the third time I’ve tried to update Endpoint Manager 15.0.41.6 but it gets to about 88% (very slowly) and then hangs. I let it run all night last night and it never did complete.

I’ve started doing updates only a few modules at a time and applying the updates after each download so that I can get at least most of the system updated.

This has happened on several modules recently. It’s as if the server is just really busy except that it’s always that way. I’m on a fiber connection and not seeing delays anywhere else. Is there a way to clear out any partial downloads that might be screwing things up? Other suggestions?

Update: After finally giving up I clicked the X to close the update window while it was still stuck at 88%. I think hit the button to apply then checked for updates again. None show in need of updating in spite of the updates not completing the download.

FreePBX 15.0.17.55


(Kapil Gupta) #2

Try to login to Freepbx Linux cli and then perform update like fwconsole ma downloadinstall endpoint --stable (or edge whatever you like).


(Jerry Warner) #3

Thank you. That worked. But why am I having a problem with the download in the first place? It didn’t fail the install. It failed the download (from the GUI, not the cli.


#4

We can do it by CLI but is there an explanation for the downloads to stall?


(Defcomllc) #5

I’ve been experiencing this when doing updates via the web gui for many months now…pretty much all of 2021…hangs, never finishes…

This is why I update via CLI with Putty. Problem free


(Jerry Warner) #6

Glad to hear I’m not the only one as that means it’s more likely to be something outside of my system.


(Lorne Gaetz) #7

What are you showing for repo:

fwconsole setting MODULE_REPO

(Jerry Warner) #8

Setting of “MODULE_REPO” is (text)[http://mirror1.freepbx.org,http://mirror2.freepbx.org]


(Lorne Gaetz) #9

Try updating to use the newest repo with:

fwconsole setting MODULE_REPO https://mirror.freepbx.org

No reason why this should work tho, both repos are up and working.


(Jerry Warner) #10

Thank you. I made the change. Of course I’ll have to wait a while to see if it works any better.

The other repos were up. Otherwise I wouldn’t have been able to get so much of the downloads. What I would see was the download would start and be progressing fine and then it would stall. If I left it alone it would tick up a few more % now and then but eventually, it would just hang totally, even overnight.

When I would click the X to close the box I’d get the button in the top right corner to apply. The interesting part is that afterward when I’d go to check for updates there often wouldn’t be one available in spite of the fact that it had never completed the download from the day before.


(Lorne Gaetz) #11

There is also the advanced setting, “Use wget For Module Admin” which can be enabled to work around uncooperative edge devices.


(Jerry Warner) #12

I’ll see how it gets along with this mirror. I try to keep my system as “standard” as possible in an effort to avoid problems down the road.


(Jared Busch) #13

The setting you changed is the new default anyway I believe.


(Jerry Warner) #14

Which one? The new repository or changing to wget for Module Admin?

I changed the repository but didn’t touch the advanced settings.


(Jared Busch) #15

Sorry, the new repository.


(system) closed #16

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.