Updated to 2.3 however


I did a Cut and Paste of the instructions to upgrade with the exception of the 2nd last line.

When I go into FreePBX it is still showing 2.2.1 and there are no modules to download in Modules Admin after doing a check for updates.

Obviously there is no extra functionality.

I am running TrixBox 2.2

Any suggestions?


You mean like so - I am still coming to grips with LINUX
Is there a later file to get instead with wget e.g. beta3?

su -
cd /usr/src/
wget http://mirror.freepbx.org/freepbx-2.3.0beta1.tar.gz
tar -zxvf freepbx-2.3.0beta1.tar.gz
cd freepbx-2.3.0beta1
./install_amp --force-version 2.2.2
amportal start


Hi Philippe,

No Web Proxy just a direct connection via a Router.

There have been no changes for months and everything else is accessing the Internet OK.

The wget worked fine when I downloaded the 2.3 Beta 1 FreePBX and the new Framework is there



I don’t really have enough information to give any more hints. If you aren’t seeing what I mentioned, then for some reason FreePBX is not connecting to the repository or you would see what I mentioned. Until you see that, ??? You could try and re-install from the tarball, do a --force-version 2.2.2 when you do that, and see if that helps.

you are having some sort of issue getting to the mirror, because if you were getting there, you would see:

FreePBX Framework setup 2.3.0beta1.3 Online upgrade available (2.3.0beta1.4)

In conjunction with a message at the top of the screen saying:

IMPORTANT: Please make sure to install/upgrade the FreepPBX Framework module, it includes some important bug fixes.

so if you aren’t seeing those, you aren’t hitting the mirror. Do you have a non-transparent web proxy or something like that?


Have tried it again several times and there are no modules shown to be upgradeable. I haven’t clicked the Red Bar yet either as I don’t want the dropped calls.

It definitely has an Internet connection as the Packages will go away and find available online files.

FreePBX Framework tool 2.3.0beta1.0 Enabled; Not available online


you should be further, for instance Framework should be at about rev .3 by now, try doing a check for online updates again.

try the upgrade again, and put --force-version 2.2.0, it should be working, it has with plenty of others.


FreePBX now shows 2.3 Beta but when I went to Module Admin and did a Check for Updates on Line there was nothing that it said was to be upgraded.

I did notice however that the FreePBX Framework is now 2.3 Beta 1.0.

Is this what you would expect and the Red Bar is there wanting to be updated although I have not done any Module uodates through Module Admin?

Thanks for getting me this far