Updated Modules and now I get a Whoops Error Userman


(Chrisk) #1

I have had freepbx running perfect for well over a month now. Tonight I updated the modules and when it finished I got this error.

/­var/­www/­html/­admin/­modules/­userman/­functions.inc/­auth/­modules/­Msad2.php766

Whoops \ Exception \ ErrorException (E_COMPILE_ERROR)
Declaration of FreePBX\modules\Userman\Auth\Msad2::getConfig() must be compatible with that of FreePBX\modules\Userman\Auth\Base::getConfig()

Please Help…

Thanks,
Chris


(Andrew Nagy) #2

fwconsole ma install userman


(Chrisk) #3

Still get a error


(Chrisk) #4

OK I ran upgradeall and it is now fixed.

however I keep getting emails saying /dev/vda2 is 77% full…
This has never happened…


(Michael Palmer) #5

I know it’s been a while, Not sure how you were able to run upgradeall, have the same issue, and fwconsole gives this same error regardless of the command issued.

Edit: Was able to edit the files in the error message and comment out the getConfig function in both files. This allowed me to run upgradeall.