Update freepbx 14 to 15


(Dejv) #1

I am trying to update my freepbx from 14 to 15 however after “Submitting data to servers…Done” it stops there.

according to the requirements everything should be in order. Any ideas ?

p.s. I tried rebooting the server just in case before updating.


#2

Were you supposed to run a distro-upgrade?
I don’t remember from 14 to 15 vs 13 to 15…


(Matt Brooks) #3

I would probably verify all most of the modules say they are running 15.x in Module Admin. You can also get a list of installed modules by running fwconsole ma list.


(Dejv) #4

I checked if there are any updates available from the GUI/Admin/Updates but everything is saying that is up to date.

These are the module versions:

[root@freepbx ~]# fwconsole ma list
No repos specified, using: [commercial,extended,standard,unsupported] from last GUI settings

±---------------------±-----------±---------±------------+
| Module | Version | Status | License |
±---------------------±-----------±---------±------------+
| accountcodepreserve | 13.0.2.2 | Enabled | GPLv2 |
| amd | 13.0.3 | Enabled | GPLv3+ |
| announcement | 13.0.7.8 | Enabled | GPLv3+ |
| areminder | 14.0.4.19 | Enabled | Commercial |
| arimanager | 13.0.5.4 | Enabled | GPLv3+ |
| asterisk-cli | 14.0.1 | Enabled | GPLv3+ |
| asteriskinfo | 13.0.7.2 | Enabled | GPLv3+ |
| asternic_cdr | 1.6.3 | Disabled | |
| backup | 14.0.10.10 | Enabled | GPLv3+ |
| blacklist | 14.0.3 | Enabled | GPLv3+ |
| broadcast | 14.0.1.13 | Enabled | Commercial |
| builtin | | Enabled | |
| bulkhandler | 13.0.19 | Enabled | GPLv3+ |
| calendar | 14.0.3.9 | Enabled | GPLv3+ |
| callaccounting | 14.0.18 | Enabled | Commercial+ |
| callback | 13.0.5.5 | Enabled | GPLv3+ |
| callerid | 13.0.8.20 | Enabled | Commercial |
| callforward | 14.0.1.3 | Enabled | AGPLv3+ |
| calllimit | 13.0.5.7 | Enabled | Commercial |
| callrecording | 14.0.16 | Enabled | AGPLv3+ |
| callwaiting | 14.0.1.1 | Enabled | GPLv3+ |
| campon | 13.0.4.1 | Enabled | GPLv3+ |
| cdr | 14.0.5.20 | Enabled | GPLv3+ |
| cel | 14.0.2.16 | Enabled | GPLv3+ |
| certman | 14.0.8.1 | Enabled | AGPLv3+ |
| cidlookup | 14.0.1.12 | Enabled | GPLv3+ |
| conferences | 13.0.23.17 | Enabled | GPLv3+ |
| conferencespro | 14.0.2.13 | Enabled | Commercial |
| configedit | 13.0.7.1 | Enabled | AGPLv3+ |
| contactmanager | 14.0.5.13 | Enabled | GPLv3+ |
| core | 14.0.28.71 | Enabled | GPLv3+ |
| cos | 13.0.12.7 | Enabled | Commercial |
| customappsreg | 13.0.5.7 | Enabled | GPLv3+ |
| customcontexts | 13.0.3.1 | Enabled | GPLv2+ |
| cxpanel | 14.0.4 | Enabled | GPLv3 |
| dahdiconfig | 14.0.1.6 | Enabled | GPLv3+ |
| dashboard | 14.0.10 | Enabled | AGPLv3+ |
| daynight | 14.0.1 | Enabled | GPLv3+ |
| dictate | 13.0.5 | Enabled | GPLv3+ |
| digium_phones | 13.0.7.4 | Enabled | GPLv2 |
| digiumaddoninstaller | 13.0.1.1 | Enabled | GPLv2 |
| directory | 13.0.19.12 | Enabled | GPLv3+ |
| disa | 13.0.6.12 | Enabled | AGPLv3+ |
| donotdisturb | 14.0.1.1 | Enabled | GPLv3+ |
| dundicheck | 2.11.0.3 | Enabled | GPLv3+ |
| endpoint | 14.0.41 | Enabled | Commercial |
| endpointman | 14.0.2.1 | Enabled | GPLv3+ |
| extensionroutes | 13.0.10.7 | Enabled | Commercial |
| extensionsettings | 13.0.4 | Enabled | GPLv3+ |
| fax | 14.0.2.8 | Enabled | GPLv3+ |
| faxpro | 14.0.13 | Enabled | Commercial |
| featurecodeadmin | 13.0.6.4 | Enabled | GPLv3+ |
| findmefollow | 14.0.1.26 | Enabled | GPLv3+ |
| firewall | 13.0.60.3 | Enabled | AGPLv3+ |
| framework | 14.0.13.34 | Enabled | GPLv2+ |
| freepbx_ha | 13.0.11 | Enabled | Commercial |
| fw_langpacks | 14.0.1 | Enabled | GPLv3+ |
| hotelwakeup | 14.0.1.6 | Enabled | GPLv2 |
| iaxsettings | 14.0.1.4 | Enabled | AGPLv3 |
| infoservices | 13.0.1.4 | Enabled | GPLv2+ |
| iotserver | 14.0.3.6 | Enabled | Commercial |
| irc | 13.0.1 | Enabled | GPLv3+ |
| ivr | 14.0.9.8 | Enabled | GPLv3+ |
| languages | 14.0.1.5 | Enabled | GPLv3+ |
| logfiles | 13.0.10.8 | Enabled | GPLv3+ |
| manager | 13.0.2.7 | Enabled | GPLv2+ |
| miscapps | 13.0.3.2 | Enabled | GPLv3+ |
| miscdests | 13.0.9 | Enabled | GPLv3+ |
| music | 13.0.22.8 | Enabled | GPLv3+ |
| oracle_connector | 14.0.1.8 | Enabled | Commercial |
| outroutemsg | 14.0.1 | Enabled | GPLv3+ |
| paging | 14.0.16.6 | Enabled | GPLv3+ |
| pagingpro | 14.0.2.29 | Enabled | Commercial |
| parking | 13.0.19.11 | Enabled | GPLv3+ |
| parkpro | 14.0.2.12 | Enabled | Commercial |
| pbdirectory | 2.11.0.6 | Enabled | GPLv3+ |
| phonebook | 13.0.6.5 | Enabled | GPLv3+ |
| phpinfo | 13.0.2 | Enabled | GPLv2+ |
| pinsets | 13.0.13 | Enabled | GPLv3+ |
| pinsetspro | 13.0.9.14 | Enabled | Commercial |
| pm2 | 13.0.7.1 | Enabled | AGPLv3+ |
| pms | 14.0.2.63 | Enabled | Commercial |
| presencestate | 14.0.1.10 | Enabled | GPLv3+ |
| printextensions | 13.0.3.2 | Enabled | GPLv3+ |
| queuemetrics | 2.11.0.3 | Enabled | GPLv3+ |
| queueprio | 13.0.7 | Enabled | GPLv3+ |
| queues | 14.0.2.31 | Enabled | GPLv2+ |
| queuestats | 14.0.1.41 | Enabled | Commercial |
| qxact_reports | 14.0.7.21 | Enabled | Commercial |
| recording_report | 14.0.3.11 | Enabled | Commercial |
| recordings | 13.0.30.14 | Enabled | GPLv3+ |
| restapi | 13.0.21.2 | Enabled | AGPLv3 |
| restapps | 14.0.22.3 | Enabled | Commercial |
| ringgroups | 14.0.1.13 | Enabled | GPLv3+ |
| rmsadmin | 13.0.14.1 | Enabled | Commercial |
| sangomacrm | 14.0.25.20 | Enabled | Commercial |
| setcid | 13.0.6.3 | Enabled | GPLv3+ |
| sipsettings | 14.0.27.28 | Enabled | AGPLv3+ |
| sipstation | 14.0.4.5 | Enabled | Commercial |
| sms | 14.0.4.6 | Enabled | Commercial |
| sng_mcu | 13.0.5 | Enabled | Commercial |
| soundlang | 14.0.10 | Enabled | GPLv3+ |
| speeddial | 2.11.0.4 | Enabled | GPLv3+ |
| superfecta | 14.0.27 | Enabled | GPLv2+ |
| sysadmin | 14.0.38.14 | Enabled | Commercial |
| timeconditions | 14.0.2.19 | Enabled | GPLv3+ |
| tts | 13.0.13 | Enabled | GPLv3+ |
| ttsengines | 13.0.7.5 | Enabled | AGPLv3 |
| ucp | 14.0.3.9 | Enabled | AGPLv3+ |
| userman | 14.0.13 | Enabled | AGPLv3+ |
| vega | 14.0.3.24 | Enabled | Commercial+ |
| versionupgrade | 14.0.12 | Enabled | Commercial |
| vmblast | 13.0.11 | Enabled | GPLv3+ |
| vmnotify | 14.0.1.7 | Enabled | Commercial |
| voicemail | 14.0.6.12 | Enabled | GPLv3+ |
| voicemail_report | 14.0.6 | Enabled | Commercial |
| vqplus | 14.0.4.15 | Enabled | Commercial |
| weakpasswords | 13.0.2 | Enabled | GPLv3+ |
| webcallback | 13.0.11.5 | Enabled | Commercial |
| webrtc | 14.0.3.8 | Enabled | GPLv3+ |
| xmpp | 14.0.1.19 | Enabled | AGPLv3 |
| zulu | 14.0.58.3 | Enabled | Commercial |
±---------------------±-----------±---------±------------+


(Matt Brooks) #5

Yeah, still on 14.x. Maybe try to run the upgrade tool again?


(Dejv) #6

Just tried it and left it running overnight still nothing :confused:


(Matt Brooks) #7

Without access to the system, I have no idea what’s wrong then. I think you have two options at this point:

  1. Try a backup of 14 and restore to 15.
  2. Purchase some commercial support from Sangoma and they can assist you with the upgrade.

(Dejv) #8

If I take a backup of the version 14, install version 15 from scratch and restore the backup it will restore everything?


(Lorne Gaetz) #9

Yes, that’s the expectation.


(Dejv) #10

ok thanks will see when I have time to install it again thanks.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.