Unusual Queue Issue

Hi There,

I’m having a very unusual problem with queues in FreePBX 2.10 and Asterisk 1.8.11 that I’m hoping someone can help me with, although it may be an asterisk issue. This was a piecemeal install and not from a FreePBX distro.

Whenever I call into a queue, the first call works exactly as expected. The second call, whether it comes in while the first is waiting or after it has left the queue, just hangs with dead air. This happens for all subsequent calls and is the same on each of the queues the phone system is operating as there are more than one.

Looking deeper, I see that the first call in to any queue has hung open after asterisk has sent it’s BYE. I cannot hangup this channel with the ‘channel request hangup’ command – asterisk indicates it is trying to hang up the call and then nothing happens. All subsequent calls hang as soon as they get into the queue and also cannot be hungup via the CLI command.

The only way to resolve this condition is to do a stop/start on amportal after which the first call into the queue restarts the issue. Fortunately it doesn’t seem to affect any other operation beyond applying FreePBX changes as a ‘queue reload’ hangs meaning that a full reload also hangs.

I have tried uninstalling and reinstalling the FreePBX queues module multiple times.
I have tried using both ring and MOH in the event it was an audio player issue.
I have tried deleting and recreating the asterisk app_queue.so module in asterisk.

Asterisk debugging doesn’t give me any information, the second call enters the queue the same as the first, however it doesn’t progress from that point. No warnings or errors beyond the fact that first call hangs in asterisk which locks up the queue functionality.

I’m about ready to wipe the whole box and start over. So if someone can figure out what is happening here to save me the effort of doing that, or confirm that is the best action, it would be much appreciated.