Unlimit duration of a call


(Hector Martin) #1

Hi,

I recently installed FreePBX 15.0.16.20.

The problem I have is the following:

  • Logo an extension on the PBX.
  • I do an outgoing call (from extension agent to destination) and this is routed correctly to the SIP Trunk.
  • After 2 hours of call (7200 seconds), this ends.

I want that this call to be always active (regardless of the time), but I’m not able to change this performance.

I have seen that in “extensions - advanced”, for each extension there is the option “maximum expiration” which by default is set to 7200. I have tried to change this parameter but the case is still the same.

Does anyone know what values should be changed so that the call isn’t end after 2 hours? Attached CDR of an example call:

Thanks & Regards,


(Lorne Gaetz) #2

There is no time limit specified by default on FreePBX. Either the provider cut the call or there is possibly a signalling failure of a reINVITE happening. I think the former to be more likely. There might be a hint at the cause in the call trace, which you can share via pastebin:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII