Uninstalled Spanish, still hearing it

Hi, i installed Spanish voice language but after hearing the echo test decided to uninstall it. It’s broken Spanish, sounds so odd.

Decided to change it to English. So I removed the Spanish audio from freepbx via the web interface and restarted both asterisk and freepbx.

Now it’s curious how if I call a random number like 999 the voice telling me that the number doesn’t exist is in English, however the voicemail number and the echo test number are still in “Spanish”

How can I change this? Tried editing asterisk.conf and uncommenting by removing the “;” character where it says “default language=en” and not even after restarting asterisk did it make any difference.

It’s not like I’m going to be calling those numbers often but I’d like to completely get rid of that broken Spanish.

I’d appreciate some help!

In Settings → Advanced Settings, what is shown for Default language? (That should only affect the GUI, though there have been posts claiming otherwise.)

In Applications → Extensions, (your extension), what is shown for Language Code? Does setting it to English (Submit and Apply Config) help?

I believe it should be

In advanced settings en_US is shown

I don’t see any language option in my extension settings.

Yes, I meant “defaultlanguage=en” just recalling from memory

The defaultlanguage for asterisk is always ‘en’, so nothing changes if you comment out or delete defaultlanguae=. all sound files are in


so in your case rm -rf /var/lib/asterisk/sounds/es would have asterisk playing the files in /var/lib/asterisk/en (so don’t ever delete that directory :wink: ) note that any custom files in /var/lib/asterisk/sounds/es/custom would need saved for later when you get an acceptable set of sounds.

rm -rf /var/lib/asterisk/sounds/es

That did it, thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.