Unchecking "Block Unknown/Blocked Caller ID" doesn't work

Unfortunately, we have a customer who can’t provide CallerID information, so I need to disable blocking of unknown callers. However, in the Blacklist module (version, when I uncheck the Block Unknown/Blocked Caller ID option and submit my changes, it won’t save the change. I tried with both Firefox and IE. Is there a manual workaround to disable that option?

You need to delete the “blocked” entry in the blacklist list.

This is regarding the “Block Unknown/Blocked Caller ID” check-box option in 2.10, not a blacklisted number.

The caller isn’t providing a phone number, so I can’t block them via the black list. I am blocking unknown callers, but I don’t want to do that because it’s blocking valid callers.

I found this in the source code:
<td><input type="checkbox" name="blocked" value="1" <? echo ($filter_blocked === true?" checked=1":"");?></td>

It looks like some PHP code isn’t getting interpreted. So, maybe I am able to disable the option, but I can’t see the change and the option will revert to being enabled whenever someone submits a change.

Does anyone know how I can check this setting outside the broken GUI?

When you check that box and apply it, you will notice that an entry is made called as I suggested “blocked”, just delete it . . .

If you have a screwy FreePBX then:-

rasterisk -x ‘database show blacklist’

will show your blacklisted number

rasterisk -x ‘database del blacklist (theentry)’

to remove it

The fix was to replace the string “<? echo” with “<?php echo” in “/var/www/html/admin/modules/blacklist/page.blacklist.php” (line 146 of 188).

I will open a bug ticket, so this gets fixed in a future release.

Thanks dicko, after fixing the file above, I was able to add a remove the unknown caller block. From the command line, it appears in the blacklist like this:
/blacklist/blocked : 1


rasterisk -x ‘database del blacklist blocked’


Now that you have figured out how to UNCHECK the ‘Block Unknown…’ box, how do you CHECK the ‘Block Unknown…’ checkbox?

I keep checking it, click on 'Submit Changes, and then click on the red ‘Apply Config’ button.

After doing this, it does place a ‘blocked’ entry in the blacklist, but the checkbox beside ‘Block Unknown…’ is not checked.

Does this mean that it is not functioning properly. I still get ‘anonymous’ calls coming through!!

I’m currently using FreePBX


Sorry, double message…

To unblock unknown/blocked Caller IDs, delete the line labeled “blocked” from the “Blacklist entries” list.