Unavailable Endpoint, Missing Contact Info

Hey there! I inherited responsibility for my company’s phone system. The person who set it up was very much so capital “I.T.” whereas I’m a bit more, “Tag, you’re ‘i.t.’.” Trying to learn this system, but not an expert by any means.

One of our Endpoints (2012) is unavailable. It still has the Aor: 2012 section but is missing the “Contact: 2012/sip:[email protected];5060;x-ast…” part. I’ve rebooted Asterisk and have checked things within reason, but I’m a bit out of my depth on this. All of our lines except for this one come back up.

A few things I know:
The network is whitelisted on the firewall.
The handset for our W60B Yealink base shows the correct local IP address ( and the button on the base locates the phone.
I used the “Secret” for the Password in the Yealink set-up. Is that correct?

I’m happy to share logs and screenshots if they are helpful in diagnosing this. The biggest question being, how do I re-establish a Contact for an Endpoint?


Secret is likely not correct. Are you using FreePBX for the PBX? You said you rebooted Asterisk did you mean rebooted FreePBX?. If you are using FreePBX when you create an extension it will randomly generate a secret for that extension you would use in the phone.

It is FreePBX. I believe that’s correct, I tried the graceful core restart.
The extension had been fine up until about a week ago and I’d rather not create a new extension for them. I believe I tried the “Password For New User” generated key, but will try again.

I think it’s possible you are generating the password in the wrong spot. FreePBX differentiates between extensions (so devices that connect to asterisk) and users (people that use said devices). You probably want to be looking in the extensions for the correct password to use here.

Thanks! I was grabbing the info from the Extension, but it turns out that wasn’t the problem. Our ISP updated our public IP address, but it wasn’t reflected in our Unifi console or elsewhere, so I didn’t think to check that. Our new IP was whitelisted and we were able to get the handset to register. It looks like everything is good now!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.