Unable to use firewall modules

I need to modify my firewall rules. When I access the firewall page it gives me the error

Call to undefined function FreePBX\modules\sysadmin_get_license()

I have tired uninstalling and reinstalling both the firewall modules and sysadmin.

My firewall version is
My sysadmin version is
My freepbx core is

I do not see an available update in module admin for either of those.

Hi @jtholt
Have you tried to add Public DNS ( on your PBX ?
I think you have not updated module such as Framework…

Pls try to add Public DNS ( && && … ) then,

fwconsole sa u
fwconsole ma refreshsignatures
fwconsole ma --edge upgradeall
fwconsole chown
fwconsole r --verbose



I have done the listed commands. All modules are now the ‘edge’ version. I still have the same error message.

Are you able to pass some screenshots here, ( you can hide FreePBX lic no and you personal details )
2- fwconsole sa i && fwconsole sa u
3- yum update -y
4- fwconols ma upgradeall
5- error screenshot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.